
 

                                   

 
 

 
 

TDSJIT3 Jitter 3 Analysis Application 
and TDSJIT3E Jitter 3 Essentials 
Adapted from the TDSJIT3 Online Help Version 2.0 
PHP020202  

 
 

 



 

2                      TDSJIT3 Jitter Analysis Application 

 
Copyright and Version Information 

Copyright © Tektronix, Inc. All rights reserved. Licensed 
software products are owned by Tektronix or its suppliers and 
are protected by United States copyright laws and international 
treaty provisions. 
Use, duplication or disclosure by the Government is subject to 
restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in 
Technical Data and Computer Software clause at DFARS 
252.227-7013, or subparagraphs (c)(1) and (2) of the 
Commercial Computer Software¾Restricted Rights clause at 
FAR 52.227-19, as applicable.  
Tektronix products are covered by U.S. and foreign patents, 
issued and pending. Information in this documentation 
supercedes that in all previously published material. 
Specifications and price change privileges reserved. 
 
Tektronix, Inc. P.O. Box 500, Beaverton, OR 97077 
TEKTRONIX, TEK, and TEKPROBE are registered trademarks 
of Tektronix, Inc. 
TDSJIT3 Jitter Analysis Measurements Online Help, OLH0202, 
Version 02.00 



Introduction 

TDSJIT3 Jitter Analysis Application                                                      3 
                                

General Safety Summary 
Review the following safety precautions to avoid injury and 
prevent damage to this product or any products connected to it. 
To avoid potential hazards, use this product only as specified. 
Only qualified personnel should perform service procedures. 
While using this product, you may need to access other parts of 
the system. Read the General Safety Summary in other system 
manuals for warnings and cautions related to operating the 
system. 
To Avoid Fire or Personal Injury: 
Connect and Disconnect Properly:  Do not connect or 
disconnect probes or test leads while they are connected to a 
voltage source. 
Observe All Terminal Ratings:  To avoid fire or shock hazard, 
observe all ratings and markings on the product. Consult the 
product manual for further ratings information before making 
connections to the product. 
Do Not Operate With Suspected Failures:  If you suspect there 
is damage to this product, have it inspected by qualified service 
personnel. 
 
Symbols and Terms: The following terms and symbols may 
appear in the online help. 

WARNING: Warning statements identify conditions 
or practices that could result in injury or loss of life.  

CAUTION: Caution statements identify conditions or 
practices that could result in damage to this product or other 
property. 
 
Terms on the Product:  The following terms may appear on the 
product: 
DANGER indicates an injury hazard immediately accessible as 
you read the marking. 
WARNING indicates an injury hazard not immediately 
accessible as you read the marking. 
CAUTION indicates a hazard to property including the product. 
Symbols on the Product: The following symbol may appear in 
the product: 

CAUTION Refer to Help 
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Introduction to TDSJIT3 
Welcome to the TDSJIT3 Jitter Analysis Application 

 
TDSJIT3 and TDSJIT3E are Java™-based applications that 
enhance basic capabilities of some Tektronix Windows-based 
oscilloscopes. These applications provides jitter analysis 
measurements that can: 
• Display the statistical results of up to six measurements 
• Show the results as plots 
• Save the measurement results to a data log file 
• Save individual data points to a measurement results file 
• Save the worst case waveforms to files 
• Select and configure multiple measurements on more than 

one channel 
Perform Random and Deterministic jitter analysis including BER 
estimation. 
To return to the Table of Contents, select Help Topics from the 
Help Top Menu. 

Using Online Help 
Online help has many advantages over a printed manual because 
of advanced search capabilities. Selecting Help on the right side 
of the application's Menu bar brings up the Help file. 
The main (opening) Help screen shows a series of book icons 
and three tabs along the top menu, each of which offers a unique 
mode of assistance: 
• Table of Contents (TOC) tab - organizes the Help into 

book-like sections. Select a book icon to open a section; 
select any of the topics listed under the book. 

• Index  tab - enables you to scroll a list of alphabetical 
keywords. Select the topic of interest to bring up the 
appropriate help page. 

• Find tab - allows a text-based search. Follow these steps: 
1. Type the word or phrase you wish to find in the search 

box. 
2. Select some matching words in the next box to narrow 

your search. 
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3. Choose a topic in the lower box, and then select the 
Display button. 

• To print a topic, select the Print button from the help topics 
menu bar. 

• Select Options from the menu bar for other commands, such 
as to annotate a topic, keep the help window on top or to use 
system colors. 

• Select the Back button to return to the previous help 
window. Sometimes you can jump from one topic to another 
through a hyperlink. If the Back button is "grayed out" or a 
jump is not available, choose the "Help Topics" button to 
return to the originating help folder.  

• Browse buttons (Next >> and Previous <<) allow you to 
move forward and backward through  topics in the order of 
the Table of Contents (TOC). 

• Sometimes you will see the bolded word, "Note," in topic 
text. This indicates important information.  

Note: 
Certain aspects of the online help are unique to applications that 
run on the oscilloscope.  
Green-underlined text indicates a Jump (hyperlink) to another 
topic. Select the green text to jump to the related topic. For 
example, select the green text to jump to the topic on Feedback.  

You can tell when the cursor is over an active hyperlink 
(button, jump, or popup), because the cursor "arrow" changes to 
a small "hand." 
Note the "light bulb" and word "Tip" in the graphic above. This 
graphic indicates additional information to help you function 
faster or more efficiently. 
 

 

Related Documentation 
In addition to the online help, you can access other information 
on how to operate the oscilloscope and application through the 
following related documents. 
Refer to the Optional Applications Software on a Windows-
Based Oscilloscope Installation Manual for the following 
information: 

• Software warranty 
• Software license agreement 
• List of all available applications, compatible oscilloscopes, 

and relevant software and firmware version numbers 
• How to apply a new label 
• Installation procedures  
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• How to enable an application 
• How to download updates from the Tektronix web site 

You can find a PDF (portable document format) file for this 
document in the Documents directory on the Optional 
Applications Software on a Windows-Based Oscilloscope 
CD-ROM. The CD booklet only contains information on 
installing the application from the CD and on how to apply 
a new label. 
For other information that will help you to use this 
application, refer to the following documents: 

• The user manual for your oscilloscope provides general 
information on how to operate the oscilloscope 

• The online help for your oscilloscope provides details on 
how to use GPIB commands to control the oscilloscope 

You can also download the file with programmer 
information and examples from the Tektronix web site. Refer to 
the installation manual for information on how to download the 
file. 
See also 
Using Online Help on Page 8 

Conventions 
Online help uses the following conventions: 
• The terms, TDSJIT3 application or "application" refer to 

both the TDSJIT3 Jitter and Timing Analysis and the 
TDSJIT3E Jitter and Timing Analysis Essentials 
Applications. 

• The term, "oscilloscope" refers to any product on which this 
application runs.  

• Displays of an oscilloscope are from a TDS7054 model; 
there may be minor differences in the displays from other 
types of oscilloscopes. 

• When steps require a sequence of selections using the 
application interface, the ">" delimiter marks each transition 
between a menu and an option. For example, one of the steps 
to recall a setup file would appear as File> Recall. 

 

Contacting Tektronix 
Phone 1-800-833-9200* 
Address Tektronix, Inc. 
Department or name (if known) 
14200 SW Karl Braun Drive 
P.O. Box 500 
Beaverton, OR 97077
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USA 
Web site http://www.tektronix.com  
Sales support 1-800-833-9200, select option 1* 
Service support 1-800-833-9200, select option 2* 
Technical support Email: techsupport@tektronix.com 
1-800-833-9200, select option 3* 
6:00 a.m. - 5:00 p.m. Pacific time 
 
*This Telephone number is toll free in North America. After 
office hours, please leave a voice mail message.  Outside 
North America, contact a Tektronix sales office or 
distributor; See the Tektronix web site for a list of offices. 

 

Feedback 
Tektronix values your feedback on our products. To help us 
serve you better, please send us suggestions, ideas, or other 
comments you may have regarding your oscilloscope. 
Direct your feedback to us through email to 
techsupport@tektronix.com or FAX at (503) 627-5695, and 
include the following information. Please be as specific as 
possible. 
General information: 
• Oscilloscope model number and hardware options, if any 
• Probes used 
• Your name, company, mailing address, phone number, FAX 

number 
• Please indicate if you would like to be contacted by 

Tektronix regarding your suggestion or comments 
Application specific information: 

• Software version number 
• Description of the problem such that technical support can 

duplicate the problem 
• If possible, save the oscilloscope waveform file as .wfm file 
• If possible, save the oscilloscope and application setup files 

from the application to obtain both the scope .set file and the 
application .ini file. 

Once you have gathered this information, you can contact 
technical support by phone or through e-mail. If using e-mail, be 
sure to enter in the subject line "TDSJIT3 Problem," and attach 
the .set, .ini, and .wfm files. 

 To include screen shots, from the oscilloscope menu bar, 
select File> Export. The Export Dialog box displays. Enter a file 
name with a .bmp extension and Save. The file is saved in the 
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C:\TekScope\Images directory. You can then attach the file to 
your email (depending on the capabilities of your email editor). 
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Getting Started 

Product Description 
The TDSJIT3 Jitter and Timing Analysis Application is a 
Java-based application that enhances basic capabilities of 
some Tektronix oscilloscopes. 
With this application you can: 
• Take jitter analysis measurements from multiple sources  
• Display the statistical results of up to six measurements 
• Display the results as plots 
• Save the results to a data log file 
• Save the worst case waveforms to files 
• Perform random and deterministic jitter analysis, including 

BER estimation 
Note:   
There are no standard accessories for this product. 

 

Differences Between TDSJIT3 and TDSJIT3E 
TDSJIT3 provides the following features that are not included in 
TDSJIT3 Essentials:  
• PLL-Based Clock Recovery 
• Crossover Voltage Analysis 
• Jitter separation (RjDj analysis) 
• Bit error rate estimation (BER) 
• Bathtub Plots 
Note:  
The setup files for TDSJIT3 and TDSJIT3E are compatible with 
each other.  
In the remainder of this document, individual feature 
descriptions that are not applicable to TDSJIT3E will include a 
note to that effect. 

How to Use the TDSJIT3 User Interface 
Here are some tips to help you use the TDSJIT3 user interface: 
• Select Source before each measurement 
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• You may select Source and Measurement multiple times to 
use different configuration options 

• Use the Single run button  to obtain a single set of 
measurements from a single run 

• Use the Run/Stop button  (free/run) to acquire 
measurements from continual runs; press the Run/Stop 
button again to stop the acquisition 

• Hints appear on the bottom status line of some TDSJIT3 
menus to help guide your choice of menu options. For 
example, on the status line of the Measurements Select 
menu, these directions appear:  "Hint:  Select a source, then 
add a measurement to create a definition." 

 

Accessories 
There are no standard accessories for this product. 
 

Compatibility 
For information on oscilloscope compatibility, refer to the 
Optional Application Software on Windows-Based Oscilloscopes 
Installation Manual. The manual is available on the Optional 
Application Software on Windows-Based Oscilloscopes CD-
ROM.  
The setup files for TDSJIT3 and TDSJIT3E are compatible with 
each other. 
The TDSJIT3E application can be run without the associated 
Option Key if you have a valid TDSJIT2 Option Key. However, 
it is recommended that you contact a Tektronix representative to 
obtain a TDSJIT3E Option Key or consider upgrading to 
TDSJIT3. 

Requirements and Restrictions 
The Sun Java Run-Time Environment V1.3.1 must be installed 
on the oscilloscope to operate the TDSJIT3 application. The 
installation of TDSJIT3 automatically installs the proper version 
of JRE. If the JRE on your oscilloscope is deleted, install 
TDSJIT3 again. 
Note: Minimum 256MB Windows PC memory is highly 
recommended. 
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Installation 
Refer to the Optional Applications Software on a Windows-
Based Oscilloscope Installation Manual for the following 
information: 
• List of applications, compatible oscilloscopes, and relevant 

software and firmware version numbers 
• How to apply a new label 
• How to Install the Application  
• How to enable an application 
• How to download updates from the Tektronix web site 
If you need to locate the corresponding Portable Document 
Format (PDF) file of this document, you can find it in the 
Documents directory on the Optional Applications Software on a 
Windows-Based Oscilloscope CD-ROM. The CD booklet only 
contains information on installing the application from the CD 
and on how to apply a new label. 
 

 
 

Connecting to a System Under Test 
You can use any compatible probes or cable interface to connect 
between your SUT (System Under Test) and oscilloscope. One 
connection is sufficient for most signals. 
The Clock-to-Data, the Crossover Voltage (TDSJIT3 only), and 
the Skew measurements require two input channels or two 
reference waveforms. 

Warning 
To avoid electric shock, you must ensure that power is removed 
from the SUT before attaching probes to it. Do not touch 
exposed conductors except with the properly rated probe tips. 
Refer to the probe manual for proper use. 
Refer to the General Safety Summary in your oscilloscope 
manual. 
See Also 
General Safety Summary (frontpiece) 
Deskewing Probes and Channels on page 59 
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Basic Operations 
About Basic Operations 

The following topics discuss the basic features and operations of 
the application. Select a link below to go to the indicated topic. 

 
 

Application Interface 
The application uses a Windows™-based interface.  
View Application Interface UI Controls.  
Note: 
The oscilloscope application shrinks to half size and appears in 
the top half of the display when the application is running. 

See Also 
Hiding and Returning to the Application on page 20 

 
 

Application Interface UI Controls 
Item Description 
Menu bar Located at the top of the application display and 

contains application menus 
Tab Tabs contain sub-menus 
Area Visual frame that encloses a set of related options 
Option button Button that defines a particular command or task 
List box Box that contains a list of items from which you can 

select one item 
Box Box that you can use to type in text, or to enter a value 

with the Keypad or a Multipurpose knob 
Scroll bar Vertical or horizontal bar at the side or bottom of a 

display area that can be used for moving around in that 
area 

Browse Displays a window where you can look through a list of 
directories and files 

Command button Button that initiates an immediate action 
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File Menu Selections 
Options Function 
Default Setup Recalls the default (startup) values for most TDSJIT3 

parameters 
*Recall Browse to select an application setup (.ini) file to recall  the 

setup file.  Recall restores the application to the values saved in 
the setup file (default path:  C:\TekApplications\tdsjit3\setup) 

*Save Save the current application settings in a .ini file (default path:  
C:\TekApplications\tdsjit3\setup) 

Recent Files Select from a list of the four most recently accessed setup files 
(saved or recalled) and recall that setup. 

Minimize Minimizes the application 
Exit Exit the application and chose to retain the current oscilloscope 

settings or restore the oscilloscope to settings prior to start of 
the application. 

*Save or Recall also triggers saving or recalling a oscilloscope setup file 
(.set) if one with a matching name is found 
 

 

How to Enter Numerical Values 
The next table lists methods that you can use to enter values in 
certain menus, such as the Autoset Ref Level menu. 

Entry Method Description 
Keypad Icon appears when you select the box; select and use to 

enter a value 
Multipurpose knob When you select the multipurpose (MP) knob, a line 

appears between the knob and the box; turn the knob on 
the oscilloscope to select a value 

  
 

Clear button 
To reset the statistical results to zero, choose the Clear button on 
the Measure menu. You do not have to wait for a measurement 
to complete to clear the results. 

 

 

Hide/Exit Buttons 
To exit the application, choose Exit from the File menu or select 
the Exit Button, , in the top right corner. When you exit the 
application, you can select to keep the oscilloscope setup 
currently in use with the application or to restore the oscilloscope 
setup that was present before you started the application. 

To Hide the application, choose the Hide button, . 
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Saving and Recalling Setups 
How to Save and Recall Setups 
You can use the File menu to save and recall different 
configuration setups and recall recently accessed files. Display 
the File Menu Selections. 
Note: 
The File> Save function saves application settings in an .ini file 
and the settings of the oscilloscope application in a .set file with 
a matching name. 
If an oscilloscope .set file with a matching name is found 
on recall of a setup file, then the oscilloscope settings are 
recalled also. If the .set file is missing or cannot be opened 
by the oscilloscope, then TDSJIT3 recalls the application 
settings and displays a message that the Recall of the .set 
file failed. 

Caution: Do not edit a setup file or recall a file not 
generated by the application. 
See Also 
Saving a Setup below 
Recalling a Saved Setup below 
Recalling the Default Setup on page 19 

Saving a Setup 
To save the application and oscilloscope settings to a setup file, 
follow these steps: 
1. Select File> Save. 
2. From the popup menu, choose the directory in which to save 

the setup file or use the current directory. 
3. Select or enter a new file name. The application appends an 

".ini" filename extension to the name of the Java setup file. 
4. Choose Save. 
Note: 
The application also saves the oscilloscope setup to a ".set" file 
when you save an application setup. Both the application ".ini" 
file and oscilloscope ".set" file have the same file name. 

Recalling a Saved Setup 
To recall the application and oscilloscope settings from a saved 
setup file, follow these steps: 
1. Select File> Recall. 
Note: You may also select File> Recent Files if the setup file 
was recently saved or recalled (in this case skip to step 4 below). 
2. From the popup menu, select the directory from which to 

recall the setup file.  
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3. Select or enter a setup file name, and then choose Open. 
4. A Recall Preview pops up, and then choose OK or Cancel. 
Note:  
The application also recalls the oscilloscope setup from a ".set" 
file when you recall an application setup. If a matching .set file is 
not found or if the .set file does not recall correctly to the 
oscilloscope, then you receive a warning that the oscilloscope 
recall failed while the Java application recall succeeded. 

 
 

Recalling the Default Setup 
To recall the application settings from the Default setup file, 
follow these steps: 
1. Select File> Default Setup. 
2. Choose OK to the Default Preview. 
Note: Most of the application selections are recalled to the 
default state. Some User Interface (UI) measurement source 
selections are not reset. 

Basic Oscilloscope Functions 
Using Basic Oscilloscope Functions 
You can use the oscilloscope Help menu to access information 
about the oscilloscope and how to use it. You can also use other 
oscilloscope functions and easily return to the application. 
To display the oscilloscope online help, follow these steps: 
1. Choose the Help> Topics from the oscilloscope menu bar. 
2. Use the Contents, TOC, or Index tabs to navigate through 

the help.  
See Also 
Minimizing and Maximizing the Application below 
Hiding and Returning to the Application on page 20 
 

Minimizing and Maximizing the Application 
 The application remains displayed when you minimize the 
oscilloscope. To minimize the application, select File> 
Minimize. 

When you minimize the application, the oscilloscope does 
not fill the screen. If you wish to do this, use the Hide button. 
 
To maximize the application, select TDSJIT3 in the toolbar at 
the bottom of the screen. 
See Also 
Hiding and Returning to the Application on page 20 
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Hiding and Returning to the Application 
When you access oscilloscope functions, the oscilloscope fills 
the display. You can access oscilloscope functions in the 
following ways:  

• Select the Hide button  in the application menu bar 
• Choose the Menu-bar or Toolbar mode on the oscilloscope 

and access menus 
• Press front-panel buttons 

To return to the application, choose the App button  on the 
Top Menu Bar of the oscilloscope. 
 
 

Application Directories and File Names 
The application uses several directories to save setup and log 
files. The application uses extensions appended to file names to 
identify the file types. 
The following table lists default directory names. 
 
Directory Used for 
C:\TekApplications\tdsjit3 Home location 
C:\TekApplications\tdsjit3\data Temporary files used 

by the application 
C:\TekApplications\tdsjit3\log Statistics log files 
C:\TekApplications\tdsjit3\measurements Log files of data points 

for each selected 
measurement 

C:\TekApplications\tdsjit3\measurementsSnapshots Measurement log files 
from Save Current 
Measurement 

C:\TekApplications\tdsjit3\setup Setup files 
C:\TekApplications\tdsjit3\waveforms Log worst case 

waveforms and 
waveform files supplied 
for use with the tutorial 
and application 
examples 

C:\TekApplications\tdsjit3\plotData Data that is exported 
from measurement 
plots. 

C:\TekApplications\tdsjit3\plotFigures Image files that are 
exported from 
measurement plots. 

 
See Also 
File Name Extensions on page 21` 
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File Name Extensions 
Extensions Descriptions
.csv Log file that uses a "comma separated variable" format
.ini Application setup file
.set Oscilloscope setup file saved and recalled with an .ini file; both

files will have the same name
.wfm Waveform file that can be recalled into a reference memory
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Taking Measurements 
About Taking Measurements 

If you want to change trigger settings or localize the 
measurement, you should do so before you take any 
measurements.  
Note: 
If you select a reference waveform as the source, you  need to 
recall and display the waveform before the application can take a 
measurement. Refer to Recalling a Waveform File.  

Note: 
If an error message displays because there are not enough cycles 
from which to take a measurement, increase the Horizontal 
Scale. 

See Also 
Clearing Measurements on page 23 

 

Selecting Sources and Measurements 
Setting Up the Application 
You can set up the application to take up to six measurements at 
the same time. In addition, you can plot the results in five plot 
types and save the statistical results to a file to review later. 
 

Specifying Input Sources 
The application takes measurements from waveforms specified 
as sources. You may select a live input channel (CH1, CH2, 
CH3, CH4), a reference waveform, or a math waveform as a 
source. 
Note: 
Most measurements require one source. The Setup, Hold, Clock-
Out, Skew and Crossover Voltage measurements require two 
input sources. 
You may select the same measurement multiple times using 
different input sources. Select the source, then select the 
measurement. 
Measurement and Source selections and their configuration 
values (if applicable) are summarized in Measurements> 
Summary of Measurements. 
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Selecting a Math Measurement 
TDSJIT3 provides four preset math equations.  
To select a Math definition: 
1. Go to the Measurements> Select> Select Source panel.  
2. Select one of the four preset equations from the drop-down 

list. 

Note: 
Select the Scope User button if you wish to measure a user-
defined math waveform (defined using the oscilloscope math 
equation editor). 
 

Selecting a Measurement 
To take a measurement, select the type of measurement in the 
Measurements menu, which is also the default opening screen of 
the application. To access the Measurements menu, go to the 
Menu bar and choose Measurements> Select> Type of 
Measurement (Clock, Data, Clock-Data, General). 
Choose and input source and then select a measurement. As you 
choose measurements, the measurement and source appears in 
the Measurements/Sources list. You may choose as many as six 
measurements for analysis. 
Note: You can make duplicate source and measurement 
selections, then choose different measurement configuration 
parameters. 

 

Clearing Measurements 
Choose the Clear All button to remove all the measurements in 
the list of selected measurements.  
To clear an individual measurement from the table: 
1. Select the associated number button on the left side of the 

table. 
(The measurement and source are highlighted.) 

2. Select the Clear button to clear the selected measurement. 
 

Selecting Sources and Measurements Menu 
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Plots 

TDSJIT3 Jitter Analysis Application                                                      25 
                                

Table of Active Measurements Areas and Options 
 

Area Option Description
Period* Elapsed time between consecutive crossings of the mid 

reference level by the waveform in the specific direction; 
see Common Cycle Start Edge. 

Frequency* Inverse of the period for each clock cycle 
Cycle-Cycle 
Period* 

Difference in period measurements from one cycle to 
the next. 

N-Cycle 
Period* 

Difference in elapsed time between tow consecutive 
groups of N-Cycles where N is a configuration object 
that you can set. 

Positive Cy-Cy 
Duty 

Difference between two consecutive positive widths. 

Negative Cy-
Cy Duty 

Difference between two consecutive negative widths. 

Positive Duty 
Cycle* 

Ratio of the positive portion of the cycle relative to the 
period. 

Negative Duty 
Cycle* 

Ratio of the negative portion of the cycle relative to the 
period. 

TIE* Difference in time between the designated edge on a 
sampled clock waveform to the designated edge on a 
calculated clock waveform with a constant frequency 
(zero jitter). 

Clock 

PLL TIE* Measurement errors relative to a timing reference that is 
recovered from a data stream by a phase locked loop 
(PLL). Available only for TDSJIT3. 

Data Period Elapsed time between when a waveform crosses a 
specific reference voltage level in the same direction 
twice. 

Data 
Frequency 

Inverse of the period for each data cycle. 

Data TIE* Difference in time between the data edges on a 
sampled data waveform to the data edges on a 
calculated data waveform with a constant rate (zero 
jitter). 

Data 

Data PLL TIE* Measurement errors relative to a timing reference that is 
recovered from a data stream by a phase locked loop 
(PLL). Available only for TDSJIT3. 

Setup Time* Elapsed time between when a data waveform crosses a 
voltage reference level followed by the clock signal 
crossing its own voltage level. 

Hold Time* Elapsed time between when the clock waveform 
crosses a voltage reference level followed by a data 
waveform crossing its won voltage level. 

Clk–Data 

Clock–Out 
Time* 

Elapsed time between when the clock waveform 
crosses a voltage reference level followed by an output 
waveform crossing its own voltage level. 
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Rise Time Elapsed time from when a rising edge crosses the low 
reference voltage level and then the high reference 
voltage level. 

Fall Time Elapsed time from when a falling edge crosses the high 
reference voltage level and then the low reference 
voltage level. 

Positive Width Amount of time a waveform remains above the mid 
reference voltage level. 

Negative Width Amount of time a waveform remains below the mid 
reference voltage level. 

High Time Amount of time a waveform remains above the high 
reference voltage level 

Low Time Amount of time a waveform remains below the low 
reference voltage level. 

Skew* Difference in time between two similar edges on the 
Main and 2nd Input waveform with the assumption that 
every edge in the Main waveform has a corresponding 
edge (either in the same or opposite polarity) in the 2nd 
waveform; edge locations are referenced to the mid 
reference voltage level. 

General 

Crossover 
Voltage* 

Edge timing is derived from the (voltage) crossover of 
differential clock or data measurements. Available only 
for TDSJIT3. 

*Requires Configuration 
  

 
 
 

Configuring Measurements 
Configuring a Measurement 
Many measurements require configuration. To access the 
Configure Measurements menu, go to the Measurements menu 
in the menu bar and choose Configure> Meas Params.  
See Also 
Clock Edge Option on page 26 
Data Edge Option on page 27  
Note: 

The following measurements do not have configuration 
options: 
• General area: Rise Time, Fall Time, Positive Width, 

Negative Width, High Time and Low Time 
• Clock area: Positive Cy-Cy Duty, and Negative Cy-Cy 

Duty 
• Data area: Data Frequency and Data Period 
In the Measurements: Configure menu, the following message 
appears on the screen when you select any of the above 
measurements:  "No configuration parameters available for 
current selection." 
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Configure: Measurement Menus 
 

 
 

Clock Edge Option 
The Clock Edge option defines which edge of the clock input is 
used to calculate statistics of the following clock-based 
measurements: 
• Frequency 
• Period 
• Cycle-Cycle 
• Positive Duty Cycle 
• Negative Duty Cycle 
The following Clock-Data measurements also have a Data Edge 
option: 
• Setup Time 
• Hold Time 
• Clk-Out 
View Example Clock Edge Configuration Menu  
See Also 
Data Edge Option on page 27 
Table of Active Measurements Areas and Options on page 25 
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Clock Edge Configuration Menu 

 
 

Data Edge Option 
In addition to a Clock Edge, the Clock-Data measurements may 
also configure a Data Edge. Data Edge defines which edge of the 
data input is used to calculate statistics on the following clock-
data based measurements: 
• Setup Time 
• Hold Time 
• Clock-Out 
View Clock and Data  Edge Configuration Example below 
See Also 
Clock Edge Option  on page 26 

 
 

Clock and Data Edge Configuration Example 
 

 
 

Clock TIE Configuration Menu 
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Clock PLL TIE Configuration Menu (available only for 
TDSJIT3) 
 

 
 
 

Data PLL TIE Configuration Menu (available only for 
TDSJIT3) 
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N-Cycle Configuration Options 
Option Description 
Clock Edge Edge used to calculate statistics 
N= Number of cycles in an N-cycle group 
1st Meas: Start 
@ Edge 

Number of cycles skipped prior to starting the 
measurement 

Edge Increment Specifies whether consecutive measurements 
(each spanning 2 N-cycles) jump forward one 
cycle (option 1) or N cycles in the waveform 
(option N) 

  
 
 

N-Cycle Period Configuration Menu 

 
 
 

Skew Configuration Options 
Option Description 

From Edge Edge on the Main waveform used to take the 
measurement 

To Edge Edge on 2nd waveform either Same as From Edge or 
Opposite of From Edge 

Meas Range Limits Minimum and maximum values in nanoseconds 
  

View Skew Configuration menu  
See Also 
Configure Measurement Menus on page 26 
 
 

Skew Configuration Menu 
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Crossover Voltage Configuration Menu (available only for 
TDSJIT3) 
 

 
 



Plots 

32                      TDSJIT3 Jitter Analysis Application 

Gating, Qualifying and Population Control 
Source Input Options 

Option Description 
Source A “live” channel, reference, or math waveform used as the 

signal source; all sources must have the same Horizontal 
Sample Rate, Record Length, and Position to assure that 
measurements function properly 

Source Autoset Changes the horizontal resolution and vertical scale and 
position for Ch1, Ch2, Ch3, and Ch4 waveforms so that 
they occupy the full vertical space available on the display 
without any part of the waveform missing (clipped); uses 
80% of the Acquisitions ADC range 

Source 
Gate/Qualify 

Methods for limiting measurements to specified regions of 
the source waveforms through gating, such as horizontal 
and vertical cursors and zoom or qualifying area with logic 
waveforms by source and active areas 

Source Ref Levels
 

Thresholds are set as a percentage of the voltage levels 
relative to the minimum and maximum levels of the peak-
to-peak values* 

     Mid Where to set the middle threshold level on the slope, in 
volts 

     Hysteresis Threshold margin, in volts, relative to the reference level 
which the voltage must cross to be recognized as 
changing; the margin is the voltage reference level plus or 
minus half the hysteresis 

     High Where on the slope, in volts, to set the high threshold level 
     Low Where on the slope, in volts, to set the low threshold level 
Stat Pop Limit Sets the maximum population used for measurements 
* The base-top method defaults to using either the Min-Max or the Low-
High Histogram.  You may select a specific Base-Top method by selecting 
the Autoset Setup button at Measurements> Configure> Source Ref 
Levels. 
  

 
Configure: Source Autoset 
Using Source Autoset 
In some cases measurement accuracy can be improved using 
Source Autoset to optimize the vertical or horizontal settings. 
Autoset Vertical Scale sets the scale so the Peak-Peak of the 
selected source is 80% of the ADC full scale. Autoset Horizontal 
Resolution sets the Sample Rate such that five samples are taken 
on the fastest rising or falling edge found on any of the 
waveforms being measured. 
To use Source Autoset: 
1. Select Measurements> Configure> Source Autoset. 
2. Select the All Vert & Horiz button to Autoset all "live" 

channels in use or you may individually set live channels by: 
• Selecting the Acq Source channel 
• Selecting Autoset Vertical Scale 
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• Selecting Autoset Horizontal Resolution 
See Source Autoset Menu below 
 
 
Source Autoset Menu 

 
Configure: Source/Gate/Qualify 
 
Configure: Source Gate/Qualify Menu 

 
 
 
 
Specifying Qualifiers 
Qualifiers allow you to focus the application on more narrowly 
defined conditions before taking measurements. This is one way 
to filter unnecessary information.  
To access the Source Gate/Qualify menu, go to the Configure 
menu in the menu bar and choose Source Gate/Qualify. 
See Also 
Configure: Gate/Qualify Menu Options below on page 33 
 
Specifying Gating Options 
Gating allows you to focus the application on a specific area of 
the waveform bound by cursors or by zoom region before taking 
measurements. This is one way to filter unnecessary information.  
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To access the Source Gate/Qualify menu, go to the 
Measurements menu and choose Configure> Source 
Gate/Qualify. 
 
  
Configure: Gating Options 

Option Description 
Zoom Zoom to specified region of source waveform and take 

measurements within the selected area 
Cursors Use oscilloscope cursors to define one specific part of the 

waveform on which to take measurements 
  

 
Configure: Source Gate/Qualify Menu Options 

  Area Description 
Source A “live” channel, reference, or math waveform used to qualify the 

signal or clock source; all sources for the measurements and 
Qualify inputs must have the same Horizontal Sample Rate, 
Record Length, and Position to assure that measurements function 
properly 

Ref Levels Select the Mid and Hysteresis Vertical Reference Level for the 
Qualify channel 

Active Specifies whether the Qualifier option is off or active when High or 
Low 

 
  

See Also 
Specifying Gating Options on page 32 
 
 
Configure: Ref Levels 
About Voltage Reference Levels 
Jitter timing measurements are based on edge times in 
waveforms. By definition, edges occur when a waveform crosses 
specified voltage reference levels. The TDSJIT3 application uses 
three basic reference levels: High, Mid and Low. In addition, a 
hysteresis value defines a voltage band that prevents a noisy 
waveform from producing spurious edges. 
The reference levels and hysteresis are independently set for 
each source waveform, and are specified separately for rising 
versus falling transitions. 
See Also 
High, Mid and Low reference levels on page 35 
Rising Versus Falling thresholds on page 81 
Using the Hysteresis Field on page 81 
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Configuring the Vertical Reference Levels 
Separate reference voltages and hysteresis are maintained for 
each source waveform. Set these levels manually or use the 
Autoset function. If used, Autoset is applied either to a specific 
source or to all currently active sources. The Autoset feature is 
also configured from the Autoset Setup button. 
To set the reference levels manually: 
1. Go to Measurements> Configure> Source Ref Levels> 

Select Source and choose a source (channel, reference or 
math waveform) for which you wish to set the reference 
levels. 
Note: You cannot select sources that are not currently active. 
Sources become active when selected for use with a 
measurement. An inactive source (not currently in use for a 
selected measurement) appears as a grayed out number on 
the button. An active source (one currently in use for a 
measurement) appears as a black number on the button. 
When you select an active source the button background 
turns white.  

2. Under Set Reference Levels, adjust the six reference levels 
and the hysteresis value. Repeat these steps for other 
sources. 

3. To set the reference levels automatically for all active 
sources, choose All Active Sources under Autoset. To 
autoset a single source, select the source and choose Autoset 
Selected Source. 

View Source Ref Level Menu  
See Also 
Configuring Ref Level Autoset on page 36 
High, Mid and Low Reference Levels on page 35  
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Source Ref Level Menu Options 

Option Description 
Select Source Identifies the source for the reference levels 

(Ch, Ref, or Math) 
Autoset 

Accesses a menu that configures how the 
Reference Level Autoset chooses the 
thresholds 
Causes threshold and hysteresis levels to be 
automatically chosen for the selected source 

     Setup   
 
 
     Selected Source 

   
   All Active Sources Causes threshold and hysteresis levels to be 

automatically chosen for all active sources 
Set Reference Level  
     Mid (Rise) 

   Mid (Fall) 
The points at which a waveform crosses its 
Mid voltage threshold define the waveform’s 
high and low states for most timing 
measurements. The Mid (Rise) threshold is 
only active when crossed in a rising direction.  
The Mid (Fall) threshold is only active when 
crossed in a falling direction. 

   Low (Rise) 
   Low (Fall) 

The Low threshold defines when a signal is 
fully in the low state for rise, fall and low time 
measurements. 

  High (Rise) 
  High (Fall) 

The High threshold defines when a signal is 
fully in the high state for rise, fall or high time 
measurements 

  Hysteresis For each threshold (High, Mid, Low), the 
waveform must fully cross a band defined by 
threshold ± hysteresis to define an edge.  The 
hysteresis never affects the location of the 
edge, it only affects whether an edge is valid 
and when the edge-finder is sensitive to 
subsequent edges  

 
High, Mid and Low Reference Levels 
The three reference levels used by TDSJIT3 are High, Mid and 
Low. 
• For many measurements, only the Mid reference level is 

used. The Mid reference level defines when the waveform 
transition occurs. 

• For Rise Time, Fall Time, High Time, and Low Time 
measurements, the High and Low reference levels define 
when the waveform is fully high or low. 

See Also 
Rising Versus Falling Thresholds on page 81 
Using the Hysteresis Field on page 81 
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Configuring Ref Level Autoset 
Autoset sets all six reference thresholds and the hysteresis value 
to percentages of the base-top voltage amplitude for the 
waveform. By default the application selects the best base-top 
method. 
To configure the Autoset function manually: 
1. Go to Measurements> Configure> Source Ref Levels and 

choose Setup, under Autoset. The Autoset Ref Level menu 
appears. 

2. Under Base-Top Method 
• Choose Min-Max to use the minimum and maximum 

values in the waveform to define the base-top amplitude.  
Note: Min-Max works well if the waveform has low noise 
and is free from excessive overshoot. 
• Choose Low - High (Histogram) to use a histogram-

based approach to define the base-top amplitude for your 
waveform 

Note: This method creates a histogram of the amplitudes of 
the waveform. The histogram should have a peak at the 
nominal high level, and another peak at the nominal low 
level. These peaks define the base-top amplitude 
• Choose Auto (the default) to enable the application to 

choose either the min-max or histogram method 
automatically 

3. You may enter the percentage for any or all values for the 
Base-Top Method. 

See Autoset Ref Level Setup Menu below. 
 
Autoset Ref Level Setup Menu 
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Autoset Ref Level Menu 

 
 

Configure: Stat Pop Limit 
Stat Pop Limit 
Use the Stat Pop Limit to set a limit on the maximum population 
to obtain for each active measurement. 
To define the maximum population for measurements: 
1. Go to Measurements> Configure> Stat Pop Limit. 
2. Select the On button. 
3. Select the Size field and select a population limit from one 

to one million. 
See Stat Pop Limit Menu below 

Note: 
Statistics individually accumulate for each measurement to the 
population limit. A Free Run stops when all active measurements 
reach the population limit. 
See Also 
Stat Pop Limit Menu Parameters on page 83  

 
 
Stat Pop Limit Menu 
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View Summaries 
About Viewing Summaries 
There are three summaries available.  
Select Measurements> Summary of to view summaries of 
measurements and configuration parameters, ref levels, or 
miscellaneous configurations (gating, qualifiers, or the stat pop 
limit). 
See Summaries Menu below. 
 

View Summaries Menu 

 
 
 

Sequencing 
Control Panel 
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Acquiring Data 
To acquire data from waveforms: 
1. Go to Results> All Statistics. 

2. Select the Run/Stop button  on the Control Panel 
(see above) for a free run continuous acquisitions or the 

Single button  for measurements on a new or 
existing acquisition. 

3. Stop sequencing by pressing the button a second time. 
Note: The status at the bottom of the screen indicates Ready 
when Sequencing is complete. It may also indicate Stopping 
prior to indicating Ready. 
See Also 
New Acq Button on page 39 

Localizing Measurements 
By specifying the trigger position, the starting point, and the 
length of the waveform, you can effectively filter out 
information that is not useful to analyze before taking a 
measurement.  
To focus the application measurement on a part of the waveform, 
you can use the Configure: Gating/Qualify menu. You can also 
adjust the Record Length, Scale, or pre-trigger information in the 
oscilloscope Horizontal menu, or the trigger level and slope in 
the Trigger menu. 
 

New Acquisition Button 
To take more than six measurements on an acquisition: 
1. Take the first six measurements using the Single run button.  
2. Choose the new acquisition button (New Acq) to change the 

default setting of Yes to No. 
3. Select and configure the next set of measurements and press 

the Single button again.  
a. When you are ready to acquire new data, select the New 

Acq button again (to change to Yes). 
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Analyzing the Results 
Analyzing the Results 
You can view the results as statistics or graphically in as many as 
four display plots. 
You can also log the data to a ".csv" file for viewing in a 
spreadsheet, database, text editor or data analysis program. 
View example of results as statistics in a .csv file with Wordpad.  
View example of how an edited ".csv" file may look in a 
spreadsheet program.  
See Also 
Viewing Statistics on page 40 
Viewing Plots on pages 40, 46 
 
 

Viewing Statistics 
To view measurement statistics, select All Statistics from the 
Results menu. The application displays results for up to six 
measurements for the current acquisition and for all acquisitions. 
The All Statistics menu contains statistical values for the 
following characteristics: 
• Population 
• Mean 
• Standard deviation (StdDev) 
• Maximum (Max)  
• Minimum (Min) 
• Pk-Pk 
• Maximum positive deviation 
• Maximum negative deviation 
 
The Results menu shows current and all 
acquisition data for each statistical value: 
View All Statistics Menu for a tabular listing of statistics for 
selected measurements. 
View Statistics: Min/Max Menu for a summary of all Min/Max 
and Max positive and negative deviations. 
View Statistics: Mean/StdDev Menu for a summary of Mean and 
Standard Deviations. 
View Statistics: TIE RjDj - BER Menu for a summary of Jitter 
decomposition for selected TIE measurements. (Available only 
in TDSJIT3) 
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All Statistics Menu 

 
 

 

Statistics: Min/Max Menu 

 
 

Statistics: Mean/StdDev Menu 
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Statistics: TIE RjDj - BER Analysis Menu (Available only in 
TDSJIT3) 

 
 
 

Saving Results to a File 
About Logging Statistics 
You can continuously log (save to file) the calculated statistics 
using TDSJIT3, or you can choose to save a snapshot of the 
current statistics.  
To log statistics go to Log> Statistics: 
1. Select measurements that you wish to log or choose "Yes to 

All" (You can also choose "No to All" if you do not wish to 
log statistics). 

2. To log Statistics continuously, select the On button. This 
starts a file browser that allows selection of an existing file 
or a new file to contain the saved statistics.  

3. Choose the Off button to stop continuous logging or the 
Delete button to delete the current statistics file. 

To save a snapshot of current statistics (as shown in the Results 
panes), under Save Current Statistics choose the Save button to 
save the current statistics to a stats.csv file.  
Note: For either type of logging, you may use the Delete button 
to browse and delete the files. 
View Log Statistics Menu  
See Also 
Log:  Statistics Options and Buttons on page 43 

 
 
 

About Logging Measurements 
You can log (save to file) the actual data points as measurement 
files. You may either log continuously or save the data points for 
the current acquisition.  
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To log measurements go to Log> Measurements> Config: 
1. Select measurements and sources that you wish to log or 

choose "Yes to All" (You can also choose "No to All" if you 
do not wish to log measurements). 

2. Under Log Measurements, select the On button to browse 
and select a directory name and start continuous 
measurement logging. 

3. Choose the Off button to stop continuous logging. 
To save current data points in measurement log files under Save 
Current Measurements, choose the Save button to browse for a 
directory and to save the snapshot. 

Note:   
For either type of logging you may use the Delete button to 
browse and delete individual measurement files. Using either 
log measurement feature provides a directory browse to 
navigate or create new folders. 

View Log Measurements Menu  
See Also 
Log: Measurements Options and Buttons  
 

Log:  Statistics Options and Buttons 
Option/button Description 

Log Statistics Enables the application to save continuously the statistical 
results for all selected measurements 

     On button Browse to select or enter a file name and turn logging on 
     Off button Turn off continuous logging 
     Delete button Browse to select and delete .csv files 
Save Current 
Statistics 

Saves a snapshot of the current statistics for the current 
acquisition and accumulated acquisitions for selected 
measurements 

     Save button Browse to select a file name and save a Snapshot of 
statistics  

     Delete Browse to select and delete .csv files 
  

See Also 
Log Statistics Menu Parameters on page 88 
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Log: Measurements Options and Buttons 
Option/button Description 

Log 
Measurements 

Enables the application to save all selected measurements 

     On button Browse to select or enter a directory name and turn logging 
on 

     Off button Turn off continuous logging 
     Delete button Browse to select and delete .csv files 
Save Current 
Measurements 

Saves a snapshot of the current measurements for the 
current acquisition and accumulated acquisitions for selected 
measurements 

     Save button Save current and accumulated measurements 
     Delete Browse to select and delete .csv files 
  

See Also 
File Names for Logging Measurement Files on page 44  

File Names for Logging Measurement Files 
You may choose a directory for measurement log files; however, 
the file names are created by a combination of measurement 
name and source chosen. 
See Also 
Logging Measurements on page 64 
 
 

Log Measurements File Names Menu 

 
 
  

Viewing a Data Log File 
You can view the measurements and statistics files .csv files 
(data log files in comma separated variable format) in a 
spreadsheet, database, text editor or data analysis program for 
further analysis.  
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You can use Notepad or Wordpad to quickly view the 
results in the data log file. 
 

Logging Worst Case Waveforms 
Worst Case Waveform logging saves the acquired waveforms 
whenever a selected measurement exceeds the highest prior 
value. When enabled, the waveforms are saved to a set of .wfm 
files.  
To log Worst Case waveforms, follow these steps: 
1. From the Menu bar, select Log> Worst Case Waveforms> 

Config. 
2. Select measurements and sources that you wish to log or 

choose "Yes to All." 
3. Select On under Log Measurements to browse and select a 

directory. 
4. To turn off logging, select the Off button. 
Note: Use the Delete button to browse and delete individual 
.wfm files. 
See Also 
Logging Worst Case Waveforms Example on page 64 
 

 

Plots 
Plot Types 

You can graphically plot the results for easier analysis. The 
following table lists the plot types: 
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Plot Description 
Histogram This plot type shows measurements sorted according to value. 

The result is a distribution of measurement values versus the 
number of times the values occurred. Determine measurement 
resolution by the span of the histogram and the number of bins 
in that span. 

Cycle Trend For the most recently processed waveform, plot the 
measurement values versus the index. For clock 
measurements, the index is equivalent to the cycle number in 
the source waveform. 

Time Trend For the most recently processed waveform, plot the 
measurement values versus the time location of the 
measurement. A Time Trend spans the same time window as 
the source waveform. Plot values before the first measurement’s 
means value. 

Spectrum For the most recently processed waveform, plot the FFT of the 
Time Trend. An analysis window may be applied to the trend 
data prior to performing the FFT. 

Bathtub For TIE type measurements with RjDj analysis activated, plot 
the BER versus the horizontal eye opening (i.e. along the time 
axis). Available only for TDSJIT3. 

 
 

 
 
Note: When taking measurements in the free run mode it is best 
to stop acquisitions before using the Create Plot menu. 

See Also 
Selecting and Viewing Plots on page 47 
Creating Plots on page 46 
About Plot Axes on page 49 
 

Plot Types and Selecting Plots 
Creating Plots 

To create a new plot, go to Plot in the menu bar and follow 
these steps: 
1. Choose Create. 
View the Create Plot menu.  
2. Select a measurement from the list of measurements. 
3. Select a plot format from the "Add Plot" buttons. The 

measurement + plot format are added to the table of defined 
plots. If results are available, the plot is created; otherwise 
the plot will appear after a measurement sequence is 
performed. 

4. Add another plot format for the current measurement, or 
select a different measurement and add associated plots. 

Note:  The Bathtub plot selection (available only for TDSJIT3) 
is only enabled when a TIE-type measurement is chosen, and 
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requires that RjDj analysis be enabled in the RjDj results area. 
Display RjDj example  
See Also 
Removing Plots on page 49 
Selecting and Viewing Plots on page 47 
About Plot Axes on page 49 

 
 

Selecting and Viewing Plots 
To view an existing plot, follow these steps: 
1. Choose the Select View button. This button appears on the 

Control Panel at the right edge of the main TDSJIT3 window 
and in the toolbar of every plot window. The Active Plot 
Summary Menu appears listing the currently defined plots. 

2. To view the first plot in the Active Plot Summary on the top 
half of the display, choose the  button from the column 
entitled "Top."   To view this plot on the bottom, choose 

 from the column entitled "Bottom."  You may place 
the other defined plots on the top or bottom of the display by 
similar steps. Choose  to bring the oscilloscope 
interface to the top of the display. Choose  to bring the 
TDSJIT3 main window to the bottom. 

3. Choose Close or  to dismiss the view selector window. 
This window is modal, so it must be dismissed before the 
TDSJIT3 windows will respond to any commands. 

 If you have a keyboard, the alt-tab Window shortcut may 
also be used to rapidly select a window for viewing. 

 If you have a second monitor, position the plot windows 
on the second monitor by clicking and dragging in the plot 
window’s title bar. 
See Also 
Plot Types on page 46 
Cursor Measurements on page 53 
About Using Zoom on page 55 
About Plot Axes on page 49 
View Create Plot Menu on page 48 
View "Locate Window at" Menu (Plots) on page 48 
View Plot Window with Controls on page 49 
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Create Plot Menu 
 

Available only for TDSJIT3

 

Active Plot Summary Menu 

 
 
Locate Window at Menu (Plots) 
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Plot Window with Controls 

 
 
 

Removing Plots 
To remove an existing plot, follow these steps.  
1. Choose Create from the Plot menu. 
2. Select a defined plot from the Plots table. 
3. Choose Clear to delete the selected plot. 
Note: Choose Clear All to delete all defined plots. 
See Also 
Creating Plots on page 46 
Selecting an existing plot for viewing on page 47 
About Plot Axes on page 49 
 
 

Plot Axes: Changing the Appearance of Plots 
About Plot Axes 
Most of the plot formats allow the appearance of the plot to be 
modified by adjusting various axis parameters. The vertical and 
horizontal axis configuration options vary from one plot format 
to another. Create, and then select the plot to adjust the axis. 
Each plot window has independent axis controls. 
To access the Vertical/Horizontal Axis menu, go to the Plots 
entry in the menu bar and choose Vert/Horiz Axis.  
Note: There are no configuration options for Cycle Trend plots. 
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Using Histogram Plots 
Histogram plots display the results such that the horizontal axis 
represents the measurement values and the vertical axis 
represents the number of times that the value occurred. Unlike 
any other plot, a histogram plot accumulates measurements over 
multiple acquisitions, up to a total population size of 2.0 billion. 
The vertical scaling (log vs. linear) can be changed at any time 
without losing the accumulated statistics. The number of bins 
can also be changed at any time, since 500 bins are always used 
for the actual computation. 

  Note:  Changing any of the horizontal scale controls 
(Center, Span, Refresh, Autoset) will cause the histogram plot to 
reset so that only the results from the most recent acquisition are 
displayed. This is because the bin size must be recalculated.  
View the Vert/Horiz Axis Menu for Histogram plots.  
See Also 
Vert/Horiz Axis Plot Options for Histogram Plots below 
Vert/Horiz Axis Plot Options for Time Trend Plots on page 51 
Vert/Horiz Axis Plot Options for Spectrum Plots on page 52 
Vert/Horiz Axis Plot Options for Bathtub Plots on page 52 
 

Vert/Horiz Axis Plot Options for Histogram Plots 

 
View the Vert/Horiz Axis Plot menu for Histogram plots on page 
51. 
See Also 
Plot Create Menu Parameters on page 86 
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Vert/Horiz Axis Plot menu for Histogram plots 

 
 
 
 

Vert/Horiz Axis Plot Option for Time Trend Plots 

 
 
 

Vert/Horiz Axis Plot Options for Spectrum Plots 
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Vert/Horiz Axis Plot Menu for Spectrum Plots 

 
 
 

Vert/Horiz Axis Plot Options for Bathtub Plots (Available only 
for TDSJIT3) 

 
  
 

Vert/Horiz Axis Plot Menu for Bathtub Plots (Available only 
for TDSJIT3) 
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Exporting Plot Information 
About Exporting Plots 

There are two ways you can export plot information from 
TDSJIT3 for use in other applications: 

• You can export the mathematical data that is represented in the 
plot figure. This may be useful if you wish to perform additional 
processing on the data.  

• You can create an image file that captures the current plot view. 
This may be a useful way to document your results. 

In support of these tasks, you will find the following export tool 
panel in the top left corner of each plot window: 

 

Note: Both export buttons are disabled whenever the application 
is actively sequencing. 

 
See Also 
Exporting raw plot data  
Exporting plot images  
 
 

Exporting Raw Plot Data 

The waveform image in each plot is typically only 500 by 160 
pixels, but the data that it represents may be several million 
samples of double-precision floating-point information. 
Exporting this data allows you to perform addition processing or 
derive custom measurements. Please note that the file sizes can 
be very large. 

To export the mathematical data that was used to create a plot, 
follow these steps: 

1. Select Data on the Export tool panel in the upper left corner of 
the plot window. A file chooser window will appear. By default, 
the chooser will provide a filename derived from the current date 
and time, and will offer to place the data in a folder called 
“plotData”, in the TDSJIT3 file area. The default data type will 
be ascii text. 
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2. Use the controls at the top of the file chooser to select the 
directory where you would like to save the data. 

3. If ascii text is not the desired data format, use the drop-down list 
labeled “Files of type:” to select another file type. The choices 
are: 

• Ascii Text (.txt) – Ascii text that is readable by an editor 
such as Wordpad 

• Comma Separated Values (.csv) – Ascii text that can be 
loaded into a spreadsheet 

• MATLAB (.mat) – Binary data in the native MATLAB 5.0 
format  

4. If you have a keyboard, you can change the filename if you wish. 

5. Choose Save to save the data. 
 

Note: Files with .txt and .csv extensions are identical except for 
the extension. 
 

 Binary files will typically use only about 40% as much 
disk space as text files. 
 
See Also 

Exporting plot images  
 

Exporting Plot Images 

You can save the exact waveform that you see in the plot 
window, including any cursors. This may be convenient for 
reports, engineering records, or sharing interesting results with 
your peers. 

To create an image file from your plot, follow these steps: 

1. Adjust the zoom and/or cursors to get the view you wish to save. 

2. Select Fig on the Export tool panel in the upper left corner of the 
plot window. A file chooser window will appear. By default, the 
chooser will provide a filename derived from the current date 
and time, and will offer to place the image file in a folder called 
“plotFigure”, in the TDSJIT3 file area. The default image format 
will be Portable Network Graphics (.png). 
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3. Use the controls at the top of the file chooser to select the 
directory where you would like to save the image. 

4. If PNG is not the desired image format, use the drop-down list 
labeled “Files of type:” to select another format. The choices are: 

• Windows Bitmap (.bmp) – This is an uncompressed pixel 
map in the standard Windows format 

• JPEG File Interchange Format (.jpg) – This is a lossy, 
compressed format 

• Portable Network Graphics (.png) – A lossless, compressed 
format that offers good portability 

5. If you have a keyboard, you can change the filename if you wish. 

6. Select Save to save the image file. 
 
See Also 

Exporting raw plot data  
 
 
 
 

Using Cursors and Zoom with Selected Measurements 
Using Horizontal and Vertical Cursors 
Cursor Measurements 
Cursor Measurements (Cursor Meas) enable you to determine 
numerical values associated with a plot based on cursor 
locations. There are two cursors and two modes of using them, 
horizontal and vertical-paired.  
Note: You can only use one mode at a time; horizontal or 
vertical-paired but not both. 
See Also 
Using Horizontal Cursors on page 53 
Using Vertical Cursors on page 53 
Vertical Cursor Example on page 54 
 
 
Using Horizontal Cursors 
Horizontal cursors appear as two cursor lines in the plot window. 
They enable you to read the vertical coordinate where each line 
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touches the plot and also view the difference (delta) between the 
two cursors. 
To use horizontal cursors while viewing a plot in the Plot 
Window: 
In the Control portion of the toolbar, select the cursors button:  

 
In the Cursors portion of the toolbar, select Horizontal Cursors: 

 
Click and drag either cursor line to move the cursor to the part of 
the plot desired. 
 
Notes on using Horizontal Cursors 

Use the  button to place the Horizontal cursors at the levels 
corresponding to the minimum and maximum values of the 
visible portion of the plot. 
Activate the Touch Screen on the oscilloscope if you prefer to 
adjust the cursors in the Plot Window screen with your fingers. 
See Also 
Using Vertical Cursors  
 
Using Vertical Cursors 
Vertical cursors appear as two vertical lines in the plot window. 
They enable you to read the horizontal coordinates where each 
line touches the plot and also view the horizontal difference 
(delta) between the two placements. 
In addition, a red cross appears where each cursor intersects the 
plotted waveform. The vertical value at each of these crosses (as 
well as the vertical delta) is shown in the Plot Window. 
To use vertical cursors while viewing a plot in the Plot Window: 
In the Control portion of the toolbar, select the cursors button: 

 
In the Cursors portion of the toolbar, select Vertical Cursors: 

 
Click and drag either cursor line to move the cursor to the part of 
the plot desired. 
See Also 
Additional Ways of Using Vertical Cursors on page 53 
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Vertical Cursors Example 

 
 
 
Additional Ways of Using Vertical Cursors 
You can use the Vertical Cursors in the following ways: 

• Use the  button to place the two cursors at the positions 
corresponding to the minimum and maximum vertical values 
within the plot. If the plot display has been zoomed, the 
minimum and maximum values within the current horizontal 
limits of the zoom are used. 

• For Time Trend only, you can use the  button to 
synchronize the oscilloscope cursors with the plot cursors’ 
positions. 

• Min/Max is most useful for Trend Plots. The max (half of 
the feature) is useful for Spectrum plots. 

See Also 

Using Plot Cursor Controls Example on page 71 

Using Horizontal Cursors on page 53 

Using Vertical Cursors on page 53 
 
 
Horizontal Cursors Example 

 



Plots 

TDSJIT3 Jitter Analysis Application                                                      59 
                                

 

Using Zoom 
About Using Zoom  
Once you have created a plot, the Zoom buttons enable you to 
examine a waveform at various scales. You can use the buttons 
in the Zoom toolbar to accomplish the following tasks: 
• Zoom in to examine a small portion of a waveform in greater 

detail. 
• Zoom out to see the entire available waveform. 
• Synchronize the scope’s zoom window with the TDSJIT3 

zoom. (Time Trend only) 
Note:  Activate the Touch Screen on the oscilloscope if you 
prefer to adjust the zoom in the  Plot Window screen with your 
fingers. 
 
 
Zooming In 
To examine a portion of a plotted waveform in greater detail: 
In the Control portion of the toolbar, select the Zoom button 

(magnifying glass icon):    This step is not 
necessary if the Zoom toolbar is already visible. 

1. In the Zoom toolbar, select Zoom In:  
2. To zoom the horizontal scale by a factor of two without 

affecting the vertical scale, click-and-release on a point of 
interest in the waveform. 

3. To zoom in by an arbitrary amount both horizontally and 
vertically, use a click-drag-release action with the mouse. 
After you click and begin dragging, a bounding box will 
appear to show what part of the waveform will be expanded 
upon release. 

The two zoom methods may be repeated in any order until the 
maximum zoom is reached. 
Zooming Out 
To reduce the scale of a plotted waveform so that more of the 
waveform can be seen: 
1. In the Control portion of the toolbar, select the zoom button:  

  This step is not necessary if the Zoom 
toolbar is already visible. 

2. To zoom out partially, select  and then click anywhere 
on the waveform. The view is restored to the zoom values 
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that existed before the most recent zoom-in. Clicking 
multiple times will restore successively earlier views. 

3. To zoom out completely, select . The view will be 
restored to its initial zoom settings, in which the entire 
waveform can be seen. 

 
 
 
Using Zoom Sync (Time Trend Only) 
By using the Zoom Sync function, you can synchronize the 
oscilloscope’s zoom window with the current horizontal axis 
limits of a Time Trend plot: 
1. Use the TDSJIT3 Zoom-in or Zoom-out buttons until the 

desired portion of the Time Trend waveform is visible. 

2. Select  in the Zoom toolbar. This turns on the 
oscilloscope’s zoom mode and adjust the scope’s horizontal 
zoom scale and position to correspond closely with those of 
the Time Trend plot. 

Notes:  

• Pressing the   button will not bring the oscilloscope’s 
user interface to the foreground if it was obscured by a 
TDSJIT3 plot window. To make the scope’s user interface 
visible, use the Select View button or the Windows alt-tab 
shortcut. See Selecting and Viewing Plots.  

• Since the oscilloscope’s zoom window has a limited number 
of valid scale factors, the time scale synchronization is not 
necessarily an exact match. 

 
 
 
 
 
 
Min/Max Button 
The Min/Max button is available with cursors and sets the 
cursors to the maximum and minimum values in both horizontal 
or vertical plots.  
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Utilities 
Warning Messages 

Warning Messages 
The application displays and saves warning messages if the input 
conditions do not support accurate measurements. You can view 
the accumulated messages in the Warnings menu. To access the 
Warnings menu, go to the Utility menu in the menu bar and 
choose Warnings. 
Note: 
To remove all of the messages, select Clear in the Warnings 
History. 
View Warning History Menu below 
See Also 
Warning History Example on page 59 
 
 
 

Warning History Menu 

 
 
See Also 
Warning History Example below 
Warning Messages pages 19, 58 
 



Utilities 

TDSJIT3 Jitter Analysis Application                                                      63 
                                

Warning History Example 

 
 

Acquisition Timeout 
Acq Timeout 
The Acq Timeout sets the delay (in seconds) the software allows 
between an acquisition start and when a waveform is expected. 
• Selecting Auto allows the software to adjust the delay 

according to the record length and measurement complexity.  
• Selecting User allows you to set the appropriate delay value 

(30 s to 86000 s in 30 s increments). 
 

Deskew 
Deskewing Probes and Channels 
To ensure accurate results for two-channel measurements, it is 
important to first deskew the probes and oscilloscope channels 
before you take measurements from your system under test 
(SUT).  
The application includes an automated deskew utility that you 
can use to deskew any pair of oscilloscope channels. Go to Steps 
to Deskew Probes and Channels. 
Note: 
To produce good deskew results; you should connect the probes 
to the fastest signal in your SUT.  
 

Steps to Deskew Probes and Channels 
To deskew a pair of probes and oscilloscope channels, follow 
these steps: 
1. Refer to the topic, Connecting to a System Under Test, 

before starting the deskew process. 
Note: In the following procedures, channel 1 (and the probe 
connected to it) is the reference point used to deskew channel 2.  
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2. Connect the probes to the fastest signal in your SUT (System 
Under Test). 

3. Set up the oscilloscope as follows: 
a. Use the Horizontal Scale knob to set the oscilloscope to 

an acquisition rate so that there are two or more samples 
on the deskew edge. 

b. Use the Vertical Scale and Position knobs to adjust the 
signals to fill the display (view the full amplitude) 
without missing any part of the signals. 

c. Set the Record Length so that there are more than 100 
edges in the acquisition. 

4. Start the application. 
5. Select Utilities> Deskew> and set the Source to Ch 1. The 

Source waveform is the reference point used to deskew the 
remaining channels. 
View the Deskew Menu  
6. Select Target Source on the Deskew Menu and set the 

Source to Ch2, the channel to deskew. 
7. Select appropriate values for Mid and Hysteresis for 

both channels. 
8. To start the deskew utility, select the Perform Deskew 

button from the Deskew Menu and answer Yes to the 
question in the box that pops up to continue the 
operation. 
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9. Do not change the Reference  Source and deskew the 
remaining channels. 
Display a sample screen produced by the Deskew utility 
when it finishes.  

 

Deskew Menu 

 
 

Deskew Complete Example 
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Tutorial 
Introduction to the Tutorial 

This tutorial teaches you how to set up the application, take two 
types of measurements, and view the results.  
Before you begin the tutorial, you must do the following tasks: 

• Set up the oscilloscope  

• Start the application  

• Recall the tutorial waveforms  
Note: Displays of an oscilloscope are from a TDS7054 model; 
there may be minor differences in the displays from other types 
of oscilloscopes. 
 

Setting Up the Oscilloscope 
To set up the oscilloscope, follow these steps: 
1. Go to the File menu in the oscilloscope menu bar and select 

Recall Default Setup to set the oscilloscope to the default 
factory settings. 

2. Press the individual CH1, CH2, CH3, and CH4 buttons as 
needed to remove active waveforms from the display. 

 

Oscilloscope Reference Memory Setup Menu 
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Oscilloscope Top Menu Bar 

 
 

Starting the Application 
To start the application, go to the File menu on the menu bar and 
select Run Application> Jitter Analysis 3. The application starts 
up and displays the Select Active Measurements menu. 
View the Measurements Select menu on page 24. 

Recalling a Waveform File 
To recall waveform files, follow these steps: 
1. Go to the File menu in the oscilloscope menu bar and access 

Reference Waveforms> Reference Setup. 
2. Select the Ref1 tab.  
3. Select the Recall button for Recall Ref1 from File. 
4. Choose the c:\TekApplications\tdsjit3\waveforms directory. 
5. Select jit3_clk.wfm file and  Recall. 
6. Select the Ref2 tab and the Recall button for Recall Ref2 

from File. 
7. Select the jit3_data.wfm file and Recall. 
8. To return to the application, choose the App button in the 

Menu bar.  
View the Oscilloscope Reference Memory setup on previous 
page. 
See Also 
Waveform Files below 
 
 

Waveform Files 
The application includes waveform files for use with this 
tutorial. The following table shows the types of signals that these 
waveforms represent. 
 

Waveform name Signal type
jit3_clk.wfm A clock signal
jit3_data.wfm A data signal

 
See Also 
Recalling a Waveform File on pages 22, 57 
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Taking a Clock Period Measurement - Part 1 
In this example, you will learn how to use the application to take 
a Clock Period measurement, how to view the results as 
statistics, and how to view the results in the various plot formats. 
To perform these lessons, the application must be installed and 
enabled on the oscilloscope. See Installation.  
To take a Clock Period measurement, follow these steps: 
1. To set the application to default values, select File> Default 

Setup. 
2. Choose Measurements Select> Clock. 
3. Select Clock Source Ref1 and select Clock Period 

measurement. 
4. Select Measurements> Configure> Source Ref Levels. Select 

Ref1 button and Autoset> Selected Source button. View the 
Autoset Ref Level Menu. 

5. Select View Summary button. Note the Summary shows the 
Ref Level values for Ref1. 

6. Choose Go to Results button.  
7. Press the Single Run command button to start the acquisition 

and display the statistical results.  

Go to Taking a Clock Period Measurement - Part 2. 
 
 
 

Taking a Clock Period Measurement - Part 2 
1. To view the results as a Histogram plot, select Plot> Create> 

Histogram (button). 
2. To view the results as a Time Trend plot, select the Time 

Trend button.  
3. To view the results as a Cycle Trend plot, select the Cycle 

Trend button.  
4. To view the results as a Spectrum plot, select the Spectrum 

button. 
5. To turn off Plots, select Clear All 
View Statistics Display Results on page 60 
 
 

Taking a Clock-to-Output Time Measurement 
In this example, you will learn how to take two measurements at 
the same time: Clock-to-Output Time and Clock Period. You 
will need two waveforms to take a Clock-Out measurement. 
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Retain the clock signal in Ref1 and the data signal in Ref2 from 
the previous lesson. You use these waveforms in both 
measurements. 
To set up the application to take a Clock-Out measurement, 
follow these steps: 
1. Select Measurements> Select> Clock-Data 
2. Select data source Ref2 and Clock-Out 
3. Clock should be Ref1 from previous lesson. 
4. Select Measurements> Configure> Ref Levels> Autoset> 

All Active Sources button 
5. Choose View Summary to check the Ref levels for both 

Ref1 and Ref2. 
6. Select Go to Results. Choose the Single Run button to start 

the acquisition. The statistical results will appear on screen. 
View sample statistical results. 

 To view the statistical results as plots, follow the steps 
outlined in Taking a Clock Period Measurement - Part 2. 

  
 

Clock to Output Statistical Results 
 Available only in TDSJIT3

 
 

Viewing a Data Log File in a Text Editor 
To view the data log file in a text editing application, such as 
WordPad or Excel, follow these steps: 
1. From the Windows tool bar, select Start icon> Programs> 

Accessories> WordPad (or Excel if available). 
2. Select File> Open. 
3. Locate the C:\TekApplications\tdsjit3\log or measurements 

or measurements snapshot directory. 
4. Select All Documents (*.*) for the Files of Type. 



Tutorial 

60                      TDSJIT3 Jitter Analysis Application 

5. Select the results.csv file and Open.  
View an example of the Statistics.csv file on the next page.  

 
 

Statistical Display Results 
Below is a sample statistical result viewed in WordPad: 
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Stats.csv File: Spreadsheet Example 

 
 
 

Log File with Default File Name 
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Stopping the Tutorial 
If you need more than one session to complete the tutorial 
lessons, you can stop the tutorial and return to it another time.  
To save the application setup and stop your session, refer to 
Saving a Setup and to Exiting the Application. 
 

Returning to the Tutorial 
To return to the tutorial setup, you can start the application and 
then recall the saved setup. To recall the application setup, refer 
to Recalling a Saved Setup on pages 18, 19, and 62 
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Application Examples 

About Application Examples 
This section presents simplified application examples that 
highlight the application measurements and give you ideas on 
how to use the application to solve your own test problems. 
To use these examples, you must have the TDSJIT3 application 
installed and enabled on the oscilloscope. For information, see 
Installation and Starting the application.  
Three application examples are presented: 
• Logging 
• RjDj Separation (available only for TDSJIT3) 
• Creating and Using Plots  
 
 

Logging 
Logging 
The following application examples show how to save the results 
of your measurements, either using Logs or Snapshots. 
With Logs, you configure the application before you run your 
tests, so that information of interest is automatically saved to a 
log file as it is produced. For example, you can obtain a detailed 
record of the measurements that result from an overnight test 
run. 
Snapshots provide a way for you to save the information that is 
currently displayed in the User Interface. For example, this is 
useful if from testing you find that a particular test run yields 
results that you would like to analyze further or archive. 
All of the following examples assume that the application is 
configured as described in Taking a Clock-to-Output Time 
Measurement.  
See Also 
Logging Statistics  

Logging Measurement  

Logging Worst-Case Waveforms  

Snapshot of Current Statistics  

Snapshot of Current Measurements  
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Logging Statistics 
The contents of a Statistics log file include a header with the 
time and date and all the measurement configurations and 
reference levels. This is followed by the information from the 
Results > All Statistics panel. There is one file for all 
measurements selected in the Log Statistics panel. 
In this example, you configure a statistics log file, run a series of 
measurements, and then look at the statistics log file that is 
produced. To set up and enable a statistics log file, follow these 
steps: 

1. Select Log> Statistics. 

2. Set Log Statistics to On. A filename selection dialog pops 
up. 

3. For the filename, type "stats1.csv".  

4. Choose the Select button. 
Note: At this point statistics logging is enabled. 

5. Select Results > All Statistics. 

6. Select Single run button,  , to start the measurements. 
The application performs the measurements and then and 
statistics are displayed in the Results panel. 

7. Go to Log> Statistics and select the Off button under Log 
Statistics. 

The statistics log file "stats1.csv" now exists in the directory 
C:\TekApplications\TDSJIT3\log.  

View a Statistics Spreadsheet Example on page 61.  

View Statistical Display Results on page 60.  
 

Logging Measurements 
The contents of each Measurement log file include a header with 
the time, date, measurement configuration and reference levels 
for a specific measurement. This is followed by rows of 
measurements, where each row contains all the instances of the 
measured parameter for one acquisition. There is one 
measurement log file for each selected measurement in the Log 
Measurements panel. 
In this example, you configure a measurements log file, run a 
series of measurements, and then look at the log file that was 
produced. To set up and enable a measurements log file, follow 
these steps: 

1. Select Log > Measurements > Config. 
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2. Set Log Measurements to On. A directory selection dialog 
will pop up. 

3. Click the OK button to accept the default director of 
c:\TekApplications\TDSJIT3\measurements. 

Note: At this point measurement logging is enabled. Select the 
File Names tab to view the file names to be used in this example: 
CPR2.csv for the Clock Period on R2; TCOR2R3.csv for the 
Clock-Out time from R2 to R3. If a file with the assigned name 
already exists in the target directory, the new file is appended to 
it. 

4. Select Results > All Statistics. 

5. Select the Single run button, , to start the measurements. 
The application performs the measurements and displays 
statistics results. 

6. Go to Log> Measurements and select the Off button under 
Log Measurements 

The log files CPR2.csv and TCOR2R3.csv now exist in the 
directory C:\TekApplications\TDSJIT3\measurements.  
 
 

Logging Worst Case Waveforms Example 
When you enable logging of worst-case waveforms, the 
TDSJIT3 application saves all the waveforms that contributed to 
the worst-case maximum value for each enabled measurement, 
and all the waveforms that contributed to the worst-case 
minimum value for each measurement.  
When a new worst-case waveform is found, all the associated 
waveforms are overwritten. The file format is the binary .wfm 
format used for waveform storage by Tektronix oscilloscopes.  
In this example, you enable logging of worst-case waveforms for 
two measurements, run a series of measurements, and then look 
at the log directory to see what files were created.  
To enable logging of worst-case waveforms, follow these steps: 

1. Select Log > Worst Case Waveforms > Config. 

2. Select the On button under Log Worst Case Waveforms. A 
dialog to help you choose a directory pops up. 

3. Click the OK button to accept the default directory of 
c:\TekApplications\TDSJIT3\waveforms. 

Note: At this point waveform logging is enabled. The names of 
the individual waveform files are not user-configurable. Select 
the File Names tab to view the file names that will be used in this 
case: CPR2Max1.wfm and CPR2Min1.wfm for the Clock Period 
measurement, and TCOR2R3Max1.wfm, TCOR2R3Min1.wfm, 
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TCOR2R3Max2.wfm and TCOR2R3Min2.wfm for the Clock-
Out measurement. 
4. Select Results > All Statistics. 
5. Select  to start the measurements. The application 

performs the measurements and displays statistics. 
6. Select Log > Worst Case Waveforms > Config and choose 

the Off button under Log Worst Case Waveforms. 
The waveform files mentioned above now exist in the directory 
C:\TekApplications\TDSJIT3\waveforms. See Recalling a 
Waveform File. 

 
 

Snapshot of Current Statistics 
A statistics snapshot is useful when you want to save the visible 
results. 
To save the results in the Results > Statistics UI panel, follow 
these steps: 
1. Select Log > Statistics. 
2. Select the No to All Button and select Clock-Out. 
3. Under Save Current Statistics, select Save. A filename 

selection dialog pops up. 
4. Type snapshot1.csv for the file name.  
5. Choose the Select button to save the current statistics for 

Clock-Out in 
c:\TekApplications\TDSJIT3\log\snapshot1.csv. 

 

Snapshot of Current Measurement 
Follow these steps to save the actual measurement results 
from the most recent acquisition:  
1. Select Log > Measurements > Config. 
2. Under Save Current Measurements, select Save. A directory 

selection dialog pops up. 
To save the measurement file for Clock-Out (as used in this and 
the other Logging Examples), select the OK button to accept the 
default directory of  
c:\TekApplications\TDSJIT3\measurementSnapshot.  
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RjDj Separation  
Note 
The RjDj separation feature is not available in TDSJIT3E. 
However, all of Part I and the first two steps in Part II can be 
performed in TDSJIT3E to display the statistical results of a 
Data TIE measurement. 

RjDj Separation Part 1 
In this example, you will learn how to use the application to 
take measurements on the random jitter and deterministic jitter 
components of the TIE jitter. Also, you will learn how to obtain 
a bathtub curve plot.  
Requirements:  
• TDS5000/6000/7000 Oscilloscope 
• TDSJIT3 Jitter and Timing Analysis Software 
• Reference waveform j3dat1.wfm (in 

C:\TekApplicaitons\TDSJIT3\waveforms\) 
Recalling Waveform: 
First, you must recall the proper Oscilloscope Reference 
Waveform. To recall j3dat1.wfm file to Ref1 on the oscilloscope, 
follow these steps:  
1. On the oscilloscope go to File> Reference Waveforms> 

Reference Setup menu>  Ref1 tab. 
2. Choose the c:\tekApplication\tdsjit3\waveforms directory.  
3. Select the j3dat1.wfm file and recall. 
At this point you should see a waveform on the oscilloscope. 
View RjDj Reference Waveform Example.  
 
Starting the Application: 
Go to File> Run Application on the oscilloscope and choose 
TDSJIT3.  
1. Go to Measurements> Select and select the Data TIE 

measurement. 
2. Go to Select Resource and select Ref1 as data resource by 

using the pull-down menu. 
3. Press the TIE button to select the TIE measurement. 
To configure the measurement, follow these steps: 
1. Press the Configure button. The Configure Measurement 

Parameters panel opens.  
2. Select the Source Ref Levels tab.  
3. Press the Autsoset All Selected Sources button. Source 

reference levels are automatically set. 
View Source Ref Levels menu. 
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See Also 
RjDj Separation Part 2 below 
RjDj  Reference Waveform Example on page 68 

 
 

RjDj Separation Part 2 
To continue the Data TIE measurement, follow these steps: 
1. Press the Go to Results button. Select the All Statistics tab.  
2. Press the application Measure Single sequence button.  
This starts the measurement process: the reference waveform in 
oscilloscope is transferred to the application,  the application 
performs timing analysis, and statistics are calculated; 
measurement results are displayed.  
Display Data TIE Measurement Results. 
To perform RjDj separation, follow these steps: 
1. Select the TIE:RjDj-BER tab.  
2. Set the Pattern Length to 40.  
3. Press the analysis ON button.  
The application performs RjDj separation and displays the 
results.  
Display RjDj Separation Results. 
 
 

Data TIE Measurement Results 
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RjDj Separation Results (Available only in TDSJIT3) 

 
 

Source Ref Levels Menu 

 
 
 

RjDj Reference Waveform Example 
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Plotting the Bathtub Curve (Available only for TDSJIT3) 
To plot the bathtub curve, follow these steps: 
1. Using the Plot/Create menu to bring up the plot panel.  
2. On the Plor panel, select Data TIE of R1. 
3. Select bathtub curve plot by pressing the Bathtub button 

from the Add Plot list. The application will place Bathtub 
plot on Data TIE of Ref1 on the plots list. The bathtub plot is 
displayed.  

4. Set the Vertical Scale to Log or Linear by using the 
Plot/Vert/Horz Axis menu. 

See example Bathtub Curve below. 
 

Bathtub Curve 

   

 

 
 

Plotting 
Creating and Using Plots 
(Some features in these examples are not supported in 
TDSJIT3E.) 
In these examples, you learn how to create and control plots that 
graphically show the results of your measurements. To prepare 
for these examples, first perform the steps in the RjDj Separation 
application example. 
The examples assume that you are using a mouse to control the 
plots, but the same actions may be performed with a finger or 
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stylus on the touch-sensitive display if Touch Screen is activated 
on the oscilloscope. 
To create a Time Trend plot of the Data TIE, follow these steps: 

1. Select Plot > Create. 

2. In the table on the left, identify the measurement to plot by 
selecting Data TIE R1. 

3. In the Add Plot panel, choose Time Trend. 

The selected measurement is added to the table of defined plots 
on the right. A new window appears on the upper half of the 
screen, containing a plot of the Data TIE versus time for REF1. 

Using Plot Zoom Controls 
When the Time Trend plot was created in the prior step, it 
automatically scaled both axes to hold the entire measurement 
from the latest acquisition (in this case, a stored waveform). In 
this example you will adjust the axis scaling so that fine details 
of the waveform can be clearly seen. 

1. In the Time Trend plot window toolbar, select the zoom 

button  if it is not already highlighted. 

2. In the Zoom area of the toolbar, select the zoom-in button 

 if it is not already highlighted. 

3. Click once with the mouse near the center of the waveform 
display area. The display zooms in (enlarges) horizontally by 
a factor of two, centered on the point that was selected. The 
vertical scaling remains fixed. 

4. Click and hold the mouse near the upper left corner of the 
waveform display area, and drag down and to the right. A 
rectangle appears, showing how much area is currently 
selected. Release the mouse when the rectangle encloses the 
area you would like to see in greater detail. The display 
zooms in both horizontally and vertically. 

5. In the Zoom area of the toolbar, select the zoom-out button 
. Click and release the mouse anywhere in the 

waveform display area. The waveform display returns to the 
zoom settings that were in effect before the most recent 
zoom-in operation.  

6. In the Zoom area of the toolbar, select the 100% button. The 
waveform display area returns to the original, "unzoomed" 
scale, which shows the entire available waveform. 

7. Select the Move Downward button  in the toolbar. The 
Time Trend plot window moves to the bottom of the overall 
display, revealing the oscilloscope display of voltage-vs-time 
on the upper half. 



Application Examples  

72                      TDSJIT3 Jitter Analysis Application 

8. On the Time Trend plot, select the zoom-in button and then 
use the mouse to click twice within the waveform display 
area. Select the sync button. In the oscilloscope display on 
the upper half of the screen, a zoomed waveform window 
appears with horizontal endpoints that closely match those in 
the Time Trend plot. 

9. Use the Front Panel Zoom button to turn off the oscilloscope 
zoom display. 

 

Using Plot Cursor Controls 
In this example you will use cursors to determine numerical 
values represented by a waveform. 

1. In the Time Trend plot window from the prior example, 
select the 100% button to restore the default zoom scale. 

2. In the Control area of the toolbar, select the cursors button 

 to switch from zoom mode to cursor mode. 

3. In the Cursors area of the toolbar, select the vertical cursors 

button . Two vertical bars appear in the waveform 
display area. Red crosses appear at the points where the bars 
cross the Time Trend waveform. The panel at the right edge 
of the plot window displays the horizontal positions of the 
two cursors, together with the vertical values of the red 
crosses. 

4. Use the mouse to click on one of the cursor bars. Without 
releasing the mouse, drag to the left or right to move the 
cursor. Release the mouse when the cursor is placed where 
you wish. 

5. Select the Min/Max button in the toolbar. One of the cursors 
snaps to the maximum value currently displayed in the plot 
window, and the other snaps to the minimum value. 

6. If the Time Trend plot window is currently on the upper half 
of the display screen, select the "move downward" button 

 in the toolbar. The Time Trend plot window moves to 
the bottom of the overall display, revealing the oscilloscope 
display of voltage-vs-time on the upper half. 

7. Select the Sync button in the Cursors area of the toolbar. On 
the oscilloscope display, the oscilloscope’s cursors are now 
positioned at the times that correspond to the cursors on the 
Time Trend plot. 
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Navigating Between Plot Windows 
This example shows you several ways to navigate between the 
scope, the TDSJIT3 main window, and up to four plot windows. 

To navigate using the view selector window: 

1. If the main TDSJIT3 application window is obscured by a plot 
window, minimize the plot window using the icon  in the 
upper right corner. 

2. Select Plot > Create. The Time Trend plot that you created in a 
prior step will already be listed in the table of defined plots. In 
the Add Plot panel, choose Histogram to add a histogram plot of 
the Data TIE measurement. 

3. Similarly, choose Spectrum and Bathtub to create two more 
plots. The plot definition panel should now look like this: 

 

 

 Available only in TDSJIT3 
 

 

4. Press the Select View button. Note that this button appears in the 
upper right corner of the TDSJIT3 main window and in the 
upper central part of each plot window. Any of these buttons will 
cause the following window to appear: 

 

 

Available only in TDSJIT3 
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5. To bring the histogram plot to the foreground, select one of the 
 buttons to the left of the histogram entry in the Active Plot 

Summary. Choose the button from the "Top" column to display 
the histogram on the upper half of the display. Choose the button 
from the "Bottom" column for display on the lower half. 

6. Close button to close the view selector window. Since the view 
selector is modal, you must close it before the controls on any 
other TDSJIT3 window will be active. 

Note: 
If you have a keyboard, use the Windows alt-tab shortcut to 
rapidly select plot windows. Hold down the alt key and press the 
tab key one or more times, until the desired plot window icon is 
highlighted in the selector. Release the alt key to bring the 
selected window to the foreground.  

 

You can also move the TDSJIT3 plot windows by dragging 
their title bars. If your oscilloscope is configured with a second 
monitor, it may be convenient to place the plot windows on the 
second display. 
 

Modifying the Plot Axis 
In this example you will use the Axis controls to modify the way 
that plots are displayed. This example assumes that you have 
created four plots as described in the RjDj application example 
and the prior sections of the Plotting example. 
To use the axis controls: 

1. Use the view selector or the alt-tab shortcut to place the 
histogram plot on the top half of the display and the 
TDSJIT3 main window on the bottom half. 

2. Choose Plot > Vert/Horiz Axis. On the left portion of the 
display, select the Data TIE Histogram entry from the 
"Select Plot" table, so that this entry is highlighted. 

3. Under "Modify Axis", use the drop-down menu titled "No of 
Bins" to choose 250 bins. 

4. Choose the "Span" control and use either the pop-up keypad 
or the multipurpose knob to adjust the span to 500ps. Choose 
"Refresh" to apply this setting to the display. The graticule 
portion of the histogram plot should now look like this: 
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5. Use the view selector to place the bathtub plot on the upper 
half of the display. In the "Select Plot" portion of the 
TDSJIT3 main window, select Bathtub. In the right half of 
the main window, the Modify Axis panel offers a choice of 
Linear or Log for the vertical scale, and allows the minimum 
displayed BER to be changed. Use either the pop-up keypad 
or the multipurpose knob to adjust the minimum displayed 
value to 10 (corresponding to BER of 1e-10). The graticule 
portion of the bathtub plot should now look like this: 

 
 

 

 

6. Choose other plot types from the "Select Plot" menu under 
Vert/Horiz Axis. Each of the plot types except Cycle Trend 
allows various axis parameters to be varied. 
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Reference 
Parameters 

About Application Parameters 
This section describes the TDSJIT3 application parameters, and 
includes the menu default settings. You should refer to the user 
manual for your oscilloscope for operating details of other 
controls, such as front-panel buttons.  
The parameters for the menus and options list the selections or 
range of values available for each and also includes the default 
values. 
Refer to the GPIB Programming section of this Help file for a 
complete list of the GPIB Command Syntax. This entry includes 
a complete list of the GPIB commands along with the arguments, 
variables, and variable values that correspond to the TDSJIT3 
parameters. 
Note:  Incremental unit values shown are valid when the FINE 
button is enabled on the oscilloscope.  
 

Measurements Menus 
Measurements: Select Menu Options 
Options available on the Select Active Measurements menu by 
area are as follows: 
• Clock area: Period, Cycle-Cycle, N-Cycle, Frequency, 

Positive Cy-Cy Duty Cycle, Negative Cy-Cy Duty Cycle, 
Positive Duty Cycle, Negative Duty Cycle, TIE, PLL TIE1  

• Data area: Period, Frequency, Data TIE and Data PLL TIE1  
• Clk-data area: Setup, Hold, and Clock-Out 
• General area: Rise Time, Fall Time, Positive Width, 

Negative Width, High Time and Low Time, Skew and 
Crossover Voltage1 

 
 

                                                      
1 These measurements are available only in TDSJIT3. 
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Configuration Menu 
Configuration Menus 
Measurements menus: 
• Meas Params 
• Source Autoset 
• Source Gate/Qualify 
• Source Ref Levels 
• Stat Pop Limit  
Measurement Parameters 
Configure Menu 
You may configure the following measurements: 
• Clock: Period, Frequency, Cycle-Cycle, N-Cycle, Positive 

Duty Cycle, Negative Duty Cycle, TIE, PLL TIE1 
• Data: Data TIE and Data PLL TIE1 
• Clk-Data (all): Setup Time, Hold Time and Clock-Out Time 
• General: Skew and Crossover Voltage1 
There is no configuration for the following measurements:  
• General: Rise Time, Fall Time, Positive Width, Negative 

Width, High Time and Low Time 
• Clock area: Positive Cy-Cy Duty and Negative Cy-Cy Duty 
• Data: Data Frequency and Data Period 
Display the parameters for the Configure Measurements menu 
and the selections or range of values for each. 
 
 

                                                      
1 These measurements are available only in TDSJIT3. 
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Configure: Measurement Parameters (Meas Param) 
Parameter Selections Default 

setting 
Clock Edge Rise, Fall, Both Rise 
N-cycle 

Active edge Rise, Fall, Both Rise 
N= 1 to 1k in 1 units 6 
1st  Meas:Start @ Edge 1 to 1k in 1 units 1 
Clock edge increment 1 or N 1 

Clock TIE 
Active Edge Rise, Fall, Both Rise 
Ref Clock Frequency Autocalc 1st Acq, Autocalc 

every Acq, User 
Autocalc 1st 
Acq 

Value (User ref clock) 1 Hz to 5 GHz in 1 Hz units 100 MHz 
Data TIE 

Ref Clock Frequency Autocalc 1st Acq. Autocalc 
Every Acq, User 

Autocalc 1st 
Acq 

Value (User ref clock) 1 Hz to 5 GHz in 1 Hz units 100 MHz 
Data PLL TIE (Available only for TDSJIT3) 
Ref Clock Frequency Autocalc 1st Acq, Autocalc 

every Acq, User 
Autocalc 1st 
Acq 

Value (User ref clock) • 1 Hz to 5 GHz in 1 Hz 
units 

100 MHz 

Clock PLL TIE (Available only for TDSJIT3) 
Active Edge Rise Fall, Both Rise 
Loop Bandwidth Standard Frequency, User Standard Freq 
Standard Speed (Gs/s) FC133:0.1328, 

FC266:0.2656, 
FC531:1.0625, 
FC1063:11.063,: 
FC2125:2.125, IB2500:2.5, 
SerATAG1:1.5, 
SerATAG2:3, SerATAG3:6, 
USB_FS:0.12, 
USB_HS:0.48, 
1394b_S400b:0.4915, 
1394b_S800b:0.983, 
1394b_S1600b:1.966, 
GB_Ethernet:1.25, 
100BaseT:0.125, 
OC1:0.0518, OC3:0.155, 
OC12:0.622, OC48:2.488 

FC133:0.1328 

Value (User only) 1 Hz to 50 MHz in 1 Hz 
units 

1 MHz 
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Data PLL TIE (Available only for TDSJIT3) 
Loop Bandwidth Standard Frequency, 

User 
Standard 
Frequency 

Standard Speed (Gs/s FC133:0.1328, 
FC266:0.2656, 
FC531:1.0625, 
FC1063:11.063,: 
FC2125:2.125, 
IB2500:2.5, 
SerATAG1:1.5, 
SerATAG2:3, 
SerATAG3:6, 
USB_FS:0.12, 
USB_HS:0.48, 
1394b_S400b:0.4915, 
1394b_S800b:0.983, 
1394b_S1600b:1.966, 
GB_Ethernet:1.25, 
100BaseT:0.125, 
OC1:0.0518, 
OC3:0.155, 
OC12:0.622, 
OC48:2.488 

FC133:0.1328 

Value 1 Hz to 50 MHz in 1 Hz 
units 

1 MHz 

Setup Time, Hold Time, Clock-Out 
Clock edge Rise Fall, Both Rise 
Data Edge  Rise Fall, Both Both 
Meas Range Limits: Max 
Value 
Min Value 

-500 ms to 500 ms in 10 ps 
units 

 
10 ns 
0 ns 

 
 

Crossover Voltage Available only for TDSJIT3 

     Main Edge Rise, Fall, Both Both 

     Meas Range Limits: Max 
Value 

-10 V to 10 V in 10 mV units 500 mV 

     Meas Range Limits: Min 
Value 

-10 V to 10 V in 10 mV units -500 mV 

Skew 
     From Edge Rise, Fall, Both Both 

     To Edge Same as From, Opposite as 
From 

Same as From 

     Meas Range Limits: Max 
Value 

-500 ms to 500 ms in 10 ps 
units 

10 ns 

     Meas Range Limits: Min 
Value 

-500 ms to 500 ms in 10 ps 
units 

-10 ns 

Note: All incremental values are with the Fine button on 
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N-Cycle Configuration Parameters 
Parameters Selections Default Setting 
Clock Edge  Rise 
N= 1 to 100,000 in 

increments of 1 edge 
1 

1st Meas: 
Start @ 
Edge 

1 to 1000 in increments 
of 1 edge 

1 

  
 
Clk-Data Area Parameters 

Selection Parameters Default Setting 
Clock Edge Rise, Fall, Both Rise 
Data Edge Rise, Fall, Both Both 
Meas 
Range 
Limits 

Max Value 
     -500 ns to 500 ns in 
     increments of 10 ps 
Min Value 
     -500 ns to 500 ns in increments  
     of 10 ps 

Max Value 10 ns 
Min Value 0 ps 

 
  

 
 

 
Clock and Data Tie Measurement Parameters 

Option Selection Default Setting 
Active Edge Rise, Fall, Both Rise 
Ref Clock Frequency Autocalc 1st Acq, Autocalc 

Every Acq, User 
Autocalc 1st Acq 

Value 1Hz to 5GHz in units of 1 Hz  100MHz* 
*Value only applies to User 
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Clock PLL TIE Measurement Parameters (available only 
for TDSJIT3) 

Parameter Selection Default Setting 
Active Edge Rise, Fall, Both Rise 
Loop Bandwidth Standard Frequency, User Standard Frequency 
Standard 
Frequency: 
     Standard 
     Speed(Gs/s) 

FC133:0.1328, FC266:0.2656, 
FC531:1.0625, FC1063:11.063,: FC2125: 
2.125, IB2500:2.5, SerATAG1:1.5, 
SerATAG2:3, SerATAG3:6, USB_FS:0.12, 
USB_HS:0.48, 1394b_S400b:0.4915, 
1394b_S800b:0.983, 1394b_S1600b:1.966, 
GB_Ethernet:1.25, 100BaseT:0.125, 
OC1:0.0518, OC3:0.155, OC12:0.622, 
OC48:2.488 

FC133:0.1328 

User 
     Value 

 
1Hz to 50 MHz in units of 1Hz  

1MHz 

  
View Clock PLL TIE Configuration Menu on page 28. 

 
 

 
Data PLLTIE Measurement Parameters (Available only for 
TDSJIT3) 

Parameter Selection Default 
Setting 

Loop Bandwidth Standard Frequency, User Standard 
Frequency 

Standard Frequency 
     Standard          
     Speed(Gs/s) 

FC133:0.1328, FC266:0.2656, 
FC531:1.0625, FC1063:11.063,: FC2125: 
2.125, IB2500:2.5, SerATAG1:1.5, 
SerATAG2:3, SerATAG3:6, USB_FS:0.12, 
USB_HS:0.48, 1394b_S400b:0.4915, 
1394b_S800b:0.983, 
1394b_S1600b:1.966, GB_Ethernet:1.25, 
100BaseT:0.125, OC1:0.0518, OC3:0.155, 
OC12:0.622, OC48:2.488 

FC133:0.1328 

User 
     Value 

 
1 Hz to 50 MHz in increments of 1 Hz 

 
1MHz 

  
View Data PLL TIE Configuration Menu on page 29. 
 
 
Skew Configuration Parameters  
Parameters Selections Default Setting 
From Edge Rise, Fall, Both Both 
To Edge Same as From, 

Opposite to From 
Same as From 

Meas Range Limits 
     Max 
     
      Min 

 
-500 to 500 ns in 
increments of of 10ps 
-500 ns to 500 ns in 
increments of 10 ps 

10 ns 
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Crossover Voltage Configuration Parameters (Available 
only for TDSJIT3) 

Parameter Selection Default Setting 
Main Edge Rise, Fall, Both Both 
Meas Range Limits: Max Value -10V to 10V in units of10mV  500mV 
Meas Range Limits: Min Value -10V to 10V  in units of 10mV  -500mV 

  
 
 
 
 
 
 
Source Autoset Menu 

 
Autoset Ref Level Setup Parameters 

Parameter Selections Default setting 
Base Top method Min-Max, Low-High 

(Histogram), Auto 
Auto (Selects best 
choice of Min/Max 
or Low-High 

Rise/Fall High 2% to 99% in 1% units 90% 
Rise/Fall Low 1% to 98% in 1% units 10% 
Rise/Fall Mid 1% to 99% in 1% units 50% 
Hysteresis 0% to 50% in 1% units 3% 
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 Autoset Ref Level Setup Menu 

 
 
Source Gate/Qualify  Menu 

 
Source Gating Menu Parameters 

Parameter Selections Default setting 
Gate Off/Zoom/Cursors  Off 
 

See Also 
Configure: Gate/Qualify Menu on page 32 
 
 
Qualify Menu Parameters 

Parameter Selections Default setting 
Source Ch 1-4, Math 1-4, or Ref 1-4 Ch4 
Active Off/High/Low Off 
 

View Configure: Gating/Qualify Menu on page 32. 
 
Rising Versus Falling Thresholds 
Specify two decision thresholds to configure each of the three 
reference levels (High, Mid, and Low).  
• A rising event occurs when the waveform rises through the 

Rise threshold.  
• A falling event occurs when the waveform falls through the 

all threshold.  
• For a given reference level, rising and falling events 

alternate as time progresses. 
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Note:  In many cases the rising and falling thresholds for a given 
reference level are set to the same value. In this case, a hysteresis 
value helps prevent spurious edges produced by small amounts 
of noise in a waveform. 

 Setting the rising threshold higher than the falling 
threshold and setting the hysteresis to zero can model the classic 
behavior of a Schmitt Trigger circuit. 
 
Using the Hysteresis Field 
Using the hysteresis field prevents small amounts of noise in a 
waveform from producing multiple threshold crossings. Use 
hysteresis when the rising and falling thresholds for a given 
reference level are set to the same value. 
The reference level ± hysteresis value defines a voltage range 
that must be fully crossed by the waveform for an edge event to 
occur. If the decision threshold is crossed more than once before 
the waveform exits the hysteresis band, the mean value of the 
first and last crossing are used as the edge event time.  
 For example, if the waveform rises through (Threshold - 
Hysteresis), then rises through Threshold, then falls through 
Threshold, then rises through both Threshold and (Threshold + 
Hysteresis), a single edge event occurs at the mean value of the 
two rising crossings. 
See Also 
Example of Hysteresis on a Noisy Waveform below 
 
 
Example of Hysteresis on a Noisy Waveform 

   
 
Source Ref Level Menu 
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Source Ref Level Menu Parameters 

Parameter Selections Default setting 
Rise/Fall High -20V to 20V in 1µV units 1V 

Rise/Fall Low -20V to 20V in 1µV units -1V 

Rise/Fall Mid -20V to 20V in 1µV units 0V 
Hysteresis 0V to 10V in 1µV units 30 mV 

 
 
View Ref Level Menu on page 83. 
 
 
Ref Level Menu 

 
 
Stat Pop Limit Menu 

 
Stat Pop Limit Menu Parameters 

Parameter Selections Default setting 
Population Control Off, On Off 
Size 1 to 1M in units of 1 1k 
 

The Stat Pop Limit applies to all active measurements.  
• As each active measurement reaches the population limit, 

TDSJIT3 stops calculating statistics 
• For measurements that have not reached the population limit, 

acquisitions and calculation of statistics continue until all 
measurements have reached the population limits 

• When all measurements reach the limit, then a Free Run 
stops  

• In a Single Run, multiple Single runs are sometimes needed 
to reach the limit. 

View Stat Pop Limit Menu on page 37. 
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Control Panel 
Control Panel Parameters 

Parameter Selections Default setting 
Single Run/Stop Stop 
Free Run Run/Stop Stop 
New Acq (Single run) Yes, No Yes 
Clear None None 
Status at bottom of screen shows if sequencing, calc RjDj, stopping, or 
ready 
  

 

Results Menus 
Results Menus 
The application includes the following Results menu parameters: 
• All Statistics  
• Min/Max  
• Mean/Std Dev  
• TIE: RjDj - BER  
 
 
Results: All Stats Menu Parameters 
Selecting a measurement tab displays all calculated statistics for 
that measurement for the current acquisition and for all 
acquisitions. 
View Results: All Stats Menu 
 
 
Results: All Stats Menu 

 

Available only for TDSJIT3

Available only for TDSJIT3 

 
 



Reference  

86                      TDSJIT3 Jitter Analysis Application 

Results: Min/Max Menu Parameters 
Parameter Selections Default Setting 
Selection of Acquisition 
type 

All Acqs, Current 
Acqs 

All Acqs 

 
 

 
 
 
Results: Min/Max Menu 

 Available only for TDSJIT3

Available only for TDSJIT3

 
 
Results: Mean/Std Dev Menu Parameters 

Parameter Selections Default Setting 
Selection of Acquisition type All Acqs, Current Acqs All Acqs 
 

 
 
 
Results:  Mean/Std Dev Menu 
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Results TIE: RjDj - BER Menu Parameters 
(Available only for TDSJIT3) 

Parameter Selections Default setting 
RjDj results are only available for 
Clock TIE, Clock PLL TIE, Data TIE, Data PLL 
TIE 

  

RjDj Analysis Off, On Off 
Pattern Length 1 to 5000 in units of 1 1 
Target BER:1.E-N 2 to 15 in units of 1 12 
 

 
Results: TIE RjDj-BER Menu (Available only for 
TDSJIT3) 

 
 
 
 

Plot Menus 
Plot Create Menu Parameters 
The Plot Create menu contains the following parameters: 
• List of Active Measurements. (Select a measurement and 

select a plot type.) 
• Add Plot type options: Histogram, Time Trend, Cycle Trend, 

Spectrum, and Bathtub1 
Note:  Bathtub plot only applies to TIE and PLL TIE type 
measurements.1  
 
 

                                                      
1 Bathtub plots are available only for TDSJIT3. 
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Plot Vert/Horiz Axis Parameters 
Parameter Selections Default Setting 
Histogram   
Vertical Scale Log Linear Linear 
No of Bins 25, 50, 100, 250, 500 50 
Horizontal Scale   

Center: Positive Time Only 1 ps to 1 s in 1 ps units 100 ns 
Center: Pos/Neg Time -500 ns to 500 ns in 1 ps 

units 
0 s 

Center: Frequency 1 Hz to 10 GHz in 1 Hz 
units 

5 GHz 

Center: Duty Cycle 0% to 100% in 5M% units 50% 
Center: Pos/Neg Volts -1 V to 1 V in 1 mV units 0 V 
Span: Positive Time Only 1 ps to 1 s in 1 ps units 4 ns 
Span: Pos/Neg Time 1 ps to 1 s in 1 ps units 4 ns 
Span: Frequency 1 Hz to 10 GHz in 1 Hz 

units 
5 GHz 

Span: Duty Cycle 0% to 100% in 5M% units 50% 
Span: Pos/Neg volts 0 V to 1 V in 1 mV units 10 mV 

Time Trend   
Mode Vector, Bar Vector 
Spectrum   
Vertical Scale Log, Linear Log 

Baseline -20 dB to 15 dB in 0.5 dB 
units 

Autoset 

Window Data None, Hanning Hanning 
Bathtub (Available only for TDSJIT3) 

Vertical Scale  Log, Linear Log 
Minimum Displayed BER=1.0e-? 
(for Log only) 

2 to 15 in 1 units 12 

  
 
 

 

Log Menu 
 
Log: Measurements Menu Parameters 

Parameter   Selections             Default setting 
Log Measurements   
Directory Path  C:\TekApplications\tdsjit3\measurements 
On/Off button On,Off Off 
Save Current Measurements   
Directory Path Save button C:\TekApplications\tdsjit3\measurements

Snapshot 
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Log Statistics Menu Parameters 
Parameter   Selections             Default setting 
Log Statistics   
     File: path and name  Any C:\TekApplications\tdsjit3\

log\stats.csv 
On/Off Button*  On, Off, Delete Off 
Save Current Statistics   
     File: path and name  Any C:\TekApplications\tdsjit3\

log\rStatsSnapshot.csv 
    Save button Save None 
   Delete button Browse to 

delete individual 
.csv files 

None 

*On saves statistics continuously until turned off 
 

 
 
 
Log: Statistics Menu 

 

Available only for TDSJIT3 

 
 
Log Measurements Menu 

 



Reference  

90                      TDSJIT3 Jitter Analysis Application 

Log Worst Case Waveforms Menu Parameters 
Parameter Selections Default setting 
On/Off  Off 
Select Directory: 
Browse 

Any directory C:\TekApplications\tdsjit3\waveforms 

Delete Browse to delete 
individual .wfm files 

None 

  
 

Utility Menu 
Utility Deskew Menu Parameters 

Parameter Selections Default setting 
Mid=-20µV to 20mV in units 
of 1µV 

Specify Deskew 
Sources 

Reference Source (Ch1-
Ch4) 

Hysteresis=1µV to 30µV in 
units of 1 µV 

 Target Source (Ch1-Ch4) Mid=0V 
Hysteresis=10mV 

Use Edges Rise 
Fall 
Both 

Rise 

Deskew Range 
 

  

     Max Value  
-24.9ns to 25.0ns in units of 
1ns 

 
1µs to - 1µs in units of 1µs 

     Min Value -25ns to 23.9 ns in 100 ps 
units 

-1ns 

Summary Popup of source and 
resultant deskew value 

None 

 
Utility Acq Timeout Menu Parameters 

Parameter Selections Default setting 
Acquisition Timeout * 30 s to 24hrs in 30s 

units 
Auto  
30s 

*In user mode TDSJIT3 waits until the Acq Timeout value for a signal before 
stopping a Single or Free Run with an error of failed to acquire signal. 
 

Utility Warnings Menu Parameters 
 Parameter Selections Default setting 
Warning History View* 

Clear 
None   
  

*View allows you to view messages in Notepad.  To save the file from 
Notepad.  
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Help Menu 
Help Menu 
There are no parameters for the Help Menu. 
 
 
 

Measurement Algorithms 
About Measurement Algorithms 
The TDSJIT3 application can take timing measurements from 
one or two waveforms. The number of waveforms used by the 
application depends on the type of measurement being taken. 
Thus, there are Types of Single Waveform Measurements and 
Types of Dual Waveform Measurements. 
See Also 
Oscilloscope Setup Guidelines  
Test Methodology  
Edge-Timing Measurements  
 

Oscilloscope Setup Guidelines 
For all measurements, use the following guidelines to set up the 
oscilloscope: 
1. The signal is any channel, reference, or math waveform. 
2. The vertical scale for the waveform must be set so that the 

waveform does not exceed the vertical range of the 
oscilloscope. 

3. The sample rate must be set small enough to capture 
sufficient waveform detail and avoid "aliasing." 

4. Longer record lengths increase measurement accuracy 
(though at the same time decreasing measurement speed). 

 

Test Methodology 
The application performs the measurement according to the 
following steps: 
1. Imports the current waveform. 
2. Checks that the reference voltage level plus or minus half 

the hysteresis are within the 2.5% to 97.5% range of the 
peak-to-peak waveform values. 

3. Checks that there are a minimum number of edges in the 
waveform to calculate the measurement as follows: 
• Single edge: Rise Time, Fall Time 
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• One edge pair: Pulse Width, High Time, Low Time 
• Two cycle-start edges: Period, Frequency, Duty Cycle 
• Three cycle-start edges: Cycle-to-Cycle, TIE, PLL TIE 
• Clock TIE and PLL TIE measurements require 500 

edges for RjDj analysis1 
• Data TIE and PLL TIE measurements require 100 

Pattern Length edges1 
• 2N + 1 cycle-start edges: N-Cycle 
• Two edges on each of two waveforms: Skew, Crossover1 

4. Performs the measurement. 
5. Displays the results as statistics, or saves the results to a data 

log file. 

Edge-Timing Measurements 
All timing measurements are based on the time locations of 
edges within each acquisition. Edge conditions are defined in the 
setup menu of each timing measurement. Tn represents the 
acquisition edge times where n is an index between 1 and the 
number of edges in the acquisition. 
The "i" and "j" represent dissimilar acquisition indices. 
Dissimilar acquisition indices occur when the correlation 
between clock edges and a data transitions are not one-to-one. 
 

RjDj Measurement (available only for TDSJIT3) 
The Rj/Dj measurement calculates the deterministic and random 
components of a jitter. The jitter is obtained from the TIE 
measurements. Rj is the random jitter. It is assumed to be 
Gaussian and has a flat spectrum. The Rj measurement calculates 
the standard deviation of the random jitter. Dj is the 
deterministic jitter. It is predictable and can be generated 
consistently given known circumstances. Dj has a spectrum of 
impulses when data signal has repeating pattern. The Dj 
measurement calculates the peak-to-peak value of the 
deterministic jitter. Tj is the total jitter, which is composed of Dj 
and Rj. The Tj measurement calculates the peak-to-peak value of 
the total jitter at the specified BER.  
To obtain measurements of Dj and Rj, the application 
distinguishes the impulse bins from noise floor bins in the 
spectrum of total jitter.  
The application calculates Rj measurement using the following 
equation: 
Rj=Standard deviation(noise floor of jitter spectrum) 
The application calculates Dj measurement using the following 
equation: 

                                                      
1 These measurements are available only in TDSJIT3. 
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)()( TimeTime DjMinDjMaxDj −=  
Where: Dj is the deterministic jitter. 

 is the time domain record of Dj obtained by performing an 
inverse FFT on Dj  spectrum which is composed of impulses. 
 
• Dj is composed of ISI, DCD and Pj:  [ISI is Inter-Symbol 

Interference. It is also called DDj ( Data Dependent Jitter). 
The ISI measurement calculates the peak-to-peak value of 
the ISI.] 

• [DCD is Duty Cycle Distortion.] It is the difference in the 
mean pulse width of positive pulse width compared to the 
mean pulse width of negative pulse width. The DCD 
measurement calculates the peak-to-peak value of the DCD. 
Pj is periodic jitter.  

• The Pj measurement calculates the peak-to-peak value of the 
Pj. 

For a data signal with a repetitive data pattern, Dj has a spectrum 
of impulses. All impulses due to ISI+DCD components must 
appear at multiples of 0.5/N where N is the data pattern length. 
Any remaining impulses are due to Pj. 
The application distinguishes the impulses appear due to 
ISI+DCD and impulses due to Pj.  
The application calculates Pj measurement using the following 
equation: 

)()( TimeTime PjMinPjMaxPj −=  
Where: Pj is the deterministic jitter. 

  is the time domain record of Pj obtained by performing an 
inverse FFT on Pj spectrum. 
The application calculates the time domain histogram of 
ISI+DCD for the rising edges and for the falling edges 
respectively.  
The application calculates ISI measurement using the following 
equation: 

( ) 2)()()()( FallFallRiseRise HMinHMaxHMinHMaxISI −+−=  
)()( FallRise HMeanHMeanDCD −=

 
Where: ISI is the inter-symbol interference. 

 DCD is the duty cycle distortion. 

 is the time domain histogram of ISI+DCD for the rising 
edges. 

 is the time domain histogram of ISI+DCD for the falling 
edges. 
See BER and Tj Estimation below on page 93. 
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BER and Tj Estimation (available only for TDSJIT3) 
The BER Estimation calculates the bit error rate curve and the 
eye open for given bit error rate. After the Rj/Dj separation, the 
recovered histogram of the total jitter can be computed. The 
recovered Tj histogram, when properly normalized, can be 
interpreted as the probability density function (PDF) of the Tj. 
 Integration of the PDF yields the CDF, which can then be used 
to create the bit error rate curve (bathtub curve). Based on the 
bathtub curve, the eye opening can be estimated for a given bit 
error rate.  
The application calculates to recovered total jitter histogram 
using the following equation: 

RjDjTj HHH ⊗=  
Where:  HTj is the recovered histogram of total jitter. 

is the histogram of Dj and is computed from the time record 
of Dj after the RjDj separation. 
  is the histogram of Rj and is synthesized based on its 
Gaussian model after the RjDj separation.  
The application calculates the Tj at the specified BER using the 
following equation: 
Tj = (1-eye opening) * UI 
Where UI is the unit interval in seconds. 
See Also 
RjDj Measurement  

 

Single Waveform Measurements 
About Single Waveform Measurements 
Conditions are defined for one waveform. 
See Also 

Oscilloscope Setup Guidelines on pages 90, 93 

Test Methodology on pages 90, 93 

Edge-Timing Measurements on pages 90, 92, and 93 
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Single Waveform Measurements 
      

Rise Time Clock Period Positive Duty Cycle 
Fall Time Clock Frequency Negative Duty Cycle  
Positive Width Cycle–Cycle Clock TIE, PLL TIE 
Negative Width N–Cycle Data Period 
High Time Positive Cycle–Cycle Duty   Data Frequency 
Low Time Negative Cycle–Cycle Duty    Data TIE, Data PLL 

TIE   
  

 
Note 
PLL TIE is available only for TDSJIT3. 
Rise Time Measurement 
The Rise Time measurement is the time difference between 
when the VRefHi reference level is crossed and the VRefLo 
reference level is crossed on the rising edge of the waveform. 
The Rise Time algorithm uses the VRef values as the reference 
voltage level. Each edge is defined by the slope, voltage 
reference level (threshold), and hysteresis.  
The application calculates this measurement using the following 
equation: 

 
Where:   TRise is the rise time. 

    THi+ is the VRefHi crossing on the rising edge. 

    TLo+ is the VRefLo crossing on the rising edge. 
 

 

Fall Time Measurement 
The Fall Time measurement is the time difference between when 
the VRefLo reference level is crossed and the VRefHi reference 
level is crossed on the falling edge of the waveform. The Fall 
Time algorithm uses the VRef values as the reference voltage 
level. Each edge is defined by the slope, voltage reference level 
(threshold), and hysteresis. 
The application calculates this measurement using the following 
equation: 

 
Where:  TFall is the fall time. 

 TLo- is the VRefLo crossing on the falling edge. 
 THi- is the VRefHi crossing on the falling edge. 
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Positive and Negative Width Measurements 
The Positive Width and the Negative Width measurements are 
the difference in time (positive or negative) between the leading 
edge and trailing edge of a pulse. The trailing edge is the 
opposite polarity (direction) of the leading edge. 
The application calculates these measurements using the 
following equations: 

 
 

Where:  W+ is the positive pulse width. 

 W- is the negative pulse width. 

  T- is the VRefMid crossing on the falling edge. 

    T+ is the VRefMid crossing on the rising edge. 
 
High Time Measurement 
The High Time Measurement is the amount of time that a 
waveform cycle is above the VRefHi voltage reference level. 
The application calculates the measurement using the following 
equation: 

 
Where:     THi is the high time. 

     THi- is the VRefHi crossing on the falling edge. 

      THi+ is the VRefHi crossing on the rising edge. 
 
Low Time Measurement 
The Low Time measurement is the amount of time that a 
waveform cycle is below the VRefLo voltage reference level. 
The application calculates this measurement using the following 
equation: 

 
Where:    TLow is the low time. 

    TLo+ is the VRefLo crossing on the rising edge. 

    TLo- is the VRefLo crossing on the falling edge. 
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Clock Frequency Measurement 
The Clock Frequency measurement calculates the inverse of the 
clock period for each cycle. 
The application calculates this measurement using the following 
equation: 

 
Where:  FClock is the clock frequency. 

              PClock is the period.  
Clock Period Measurement 
The Clock Period measurement calculates the duration of a cycle 
as defined by a start and a stop edge. Edges are defined by slope, 
threshold, and hysteresis. 
The application calculates this measurement using the following 
equation: 

 
Where:  PClock is the clock period.  

T is the VRefMid crossing time in the Common Cycle 
Start Edge direction. 

 
Clock Cycle-to-Cycle Measurement 
The Clock  Cycle–to–Cycle measurement calculates the 
difference in period measurements from one cycle to the next. 
The application calculates this measurement using the following 
equation: 

 
Where:    ∆P is the difference between adjacent periods. 
    PClock is the period. 
 
Clock N-Cycle Measurement 
The N-Cycle measurement calculates the difference in clock 
period  measurements from cycles that are a defined number of 
cycles apart.  
The application calculates this measurement using the following 
equation: 

 
Where:  ∆∆∆∆NP is the difference between adjacent N–cycle 
periods.  
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 T+ is the VRefMid crossing time in the Common Cycle Start 
Edge direction. 
 
Clock Positive and Negative Cycle to Cycle Duty 
Measurements 
The Positive Cycle-to-Cycle Duty and Negative Cycle-to-Cycle 
Duty measurements calculate the ratio of the positive (or 
negative) portion of the cycle relative to the period from one 
cycle to the next. 
The application calculates these measurements using the 
following equations: 

 
Where:   ∆∆∆∆W+ is the positive cycle-to-cycle duty. 
   ∆∆∆∆W- is the negative cycle-to-cycle duty. 

  W+ is the positive pulse width. 
  W- is the negative pulse width. 

 
Clock Positive and Negative Duty Cycle 
Measurements 
The Positive Duty Cycle and Negative Duty Cycle 
measurements calculate the ratio of the positive (or negative) 
portion of the cycle relative to the period.  

 
The application calculates these measurements using the 
following equations: 

Where:    D+ is the positive duty cycle. 

   D- is the negative duty cycle. 

   W+ is the positive pulse width. 

   W- is the negative pulse width. 

   PClock is the period. 

 
Clock TIE Measurement 
The Clock TIE measurement calculates the difference in time 
between the designated edge on a sampled clock waveform to 
the designated edge on a calculated clock waveform with a 
constant frequency (zero jitter). 
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The application calculates this measurement using the following 
equation: 

 

Where:   is the clock time interval error. 

              Tn is the specified clock edge. 

              T ′n is the calculated ideal clock edge. 
 
Clock PLL TIE Measurement (available only for 
TDSJIT3) 
The Clock PLL TIE measurement calculates the difference in 
time between the designated edge on a sampled clock waveform 
to the designated edge on a clock waveform calculated by means 
of a PLL. Low frequency TIE components that are within the 
loop bandwidth of the PLL are tracked by the PLL and thereby 
removed.  
The application calculates this measurement using the following 
equation: 

 

Where:      is the clock time interval error. 

     Tn is the specified clock edge. 

     T ′n is the recovered clock edge by means of a PLL. 
 

 

Data Frequency Measurement 
The Date Frequency measurement calculates the inverse of the 
data period for each cycle. 
The application calculates this measurement using the following 
equation: 

 

Where:     is the data frequency. 

     P is the period.  
 
Data Period Measurement 
The Date Period measurement calculates the duration of a cycle 
as defined by a start and a stop edge. Edges are defined by slope, 
threshold, and hysteresis. 



Reference  

100                      TDSJIT3 Jitter Analysis Application 

The application calculates this measurement using the following 
equation: 

 

Where:     is the data period. 

  is the VRefMid crossing time in either direction. 

   is the calculated clock cycle location of . 
 
Data TIE Measurement  
The Data TIE measurement calculates the difference in time 
between the designated edge on a sampled data waveform to the 
designated edge on a calculated data waveform with a constant 
frequency (zero jitter). 
The application calculates this measurement using the following 
equation: 

 

Where:   is the data time interval error. 

 is the data edge, the VRefMid crossing time in  
either direction. 

 is the calculated ideal data edge time. 
 

Data PLLTIE Measurement (available only for 
TDSJIT3) 
The Data PLL TIE measurement calculates the difference in time 
between the designated edge on a sampled data waveform to the 
designated edge on a data waveform calculated by means of a 
PLL. Low frequency TIE components that are within the loop 
bandwidth of the PLL are tracked by the PLL and thereby 
removed.  
The application calculates this measurement using the following 
equation: 

 

Where:   is the data time interval error. 

 is the data edge, the VRefMid crossing time in        
either direction. 

  is the recovered data edge by means of a PLL. 
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Dual Waveform Measurements 
About Dual Waveform Measurements 
Edge conditions are defined for two waveforms. These 
algorithms use the VRef values as the reference voltage level. 
Each edge is defined by the slope, voltage reference level 
(threshold), and hysteresis. 
See Also 

Oscilloscope Setup Guidelines on pages 90, 93 

Test Methodology on pages 90, 93 

Edge-Timing Measurements on pages 90, 92, and 93 
 
Dual Waveform Measurements 

 
Setup Time  
Hold Time 
Clock-Out 
Skew 
Crossover Voltage 
  

Setup Time Measurement 
The Setup Time measurement is the elapsed time between the 
designated edge of a data waveform and when the clock 
waveform crosses its own voltage reference level. The closest 
data edge to the clock edge that falls within the range limits is 
used. 
The application calculates this measurement using the following 
equation: 

 

Where:  is the setup time. 

T is the Main input (clock)  crossing time in 
the specified direction.  

is the 2nd input (data)  crossing time in 
the specified direction.  
 
Hold Time Measurement 
The Hold Time measurement is the elapsed time between when 
the clock waveform crosses its own voltage reference level and 
the designated edge of a data waveform. The closest data edge to 
the clock edge that falls within the range limits is used. 
The application calculates this measurement using the following 
equation: 
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Where:  THold is the hold time. 

T is the Main input (clock)  crossing time in 
the specified direction.  

            is the 2nd input (data)  crossing time in 
 the specified direction.  

 
Clock-Out Measurement 
The Clock–to–Output Time measurement is the elapsed time 
between when the clock  waveform crosses its own voltage 
reference level and the designated edge of a data waveform. The 
closest data edge to the clock edge that falls within the range 
limits is used. 
The application calculates this measurement using the following 
equation: 

 

 Where:   is the clock-to-output time. 

    T is the Main input (clock)   

     crossing time in the specified direction. 

    is the 2nd input (data)   

    crossing time in the specified direction.  
 

Skew Measurement 
The Skew measurement calculates the difference in time 
between the designated edge on a principle waveform to the 
designated edge on another waveform. The closest data edge to 
the clock edge that falls within the range limits is used. 

The application calculates this measurement using the following 
equation: 

 
Where:  S is the period. 

   T is the Main input  crossing time in the  

              specified direction.  

     is the 2nd input  crossing time in the  

               specified direction.  
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Crossover Voltage Measurement (available only 
for TDSJIT3) 
The Skew measurement calculates the voltage level at the 
crossover voltage of a differential signal pair. If there is timing 
jitter on one of the pair of signal lines relative to the other, the 
crossover point will be modulated by the jitter. Crossover times 
are determined from the math waveform (main-cross) for a 
reference level of 0V.  

The application calculates this measurement using the following 
equation: 

 

)(TVV Crossover
n

MainCrossover

n =  
 

Where:   is the crossover voltage. 

              is the voltage of the Main input.  

              is the crossover time. It is the time when two   
 waveforms crossover in the specified direction.  

 
 

Calculating Statistics 
Maximum Value 
The application calculates this statistic using the following 
equation: 

 
 
Minimum Value 
The application calculates this statistic using the following 
equation: 

 
 
Mean Value 
The application calculates this statistic using the following 
equation: 
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Standard Deviation Value 
It may seem odd that the equation for the estimate of the 
Standard Deviation contains a 1/(N-1) scaling factor. If you 
knew the true mean of X and used in  place of the estimated 
mean , then you would, in fact, scale by1/N. But,  is an 
estimate and is likely to be in error (or bias), causing the estimate 
of the Standard Deviation to be too small I scaled by 1/N. This is 
the reason for the scaling shown in the equation. (Refer to 
Chapter 9.2 in A. Papoulis, Probability, Random Variables, and 
Stochastic Processes, McGraw Hill, 1991.) 
The application calculates this statistic using the following 
equation: 

 
 
 
Max Positive and Negative Difference Values 
The application calculates the Max Positive Difference Value 
using the following equation: 

 
The application calculates Max Negative Difference Value using 
the following equation: 

 
The Cycle-Cycle Value below is not displayed, but is used in 
calculations for Max Positive and Max Neg calculations. 

 
Population Value 
The application calculates this statistic using the following 
equation: 

 
 

GPIB Programming 
GPIB Command Syntax 
Introduction to GPIB Command Syntax 
With knowledge of the GPIB command syntax, you can design a 
GPIB program to do the following tasks: 
• Start the TDSJIT3 application 
• Recognize an active application with GPIB protocol 
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• Program and read application setup parameters 
• Sequence measurements 
• Read measurement results 
See Also 
GPIB Reference Materials below 

             Variable:Value Jitter3  Command on page 104 
Variable Value Jitter3 Command Arguments and Queries 
beginning on page 105 
Measurements Results Queries on page 108 
 
 
GPIB Reference Materials 
To use GPIB commands with your oscilloscope, you can use the 
following reference materials: 
• The tdsjit3ctrl.c file on the oscilloscope hard drive (located 

in the C:\Program Files\TekApplications\tdsjit3 directory) 
and optional applications compact disc for an example of a 
GPIB program that can execute the application 

• The GPIB Program Example section for guidelines to use 
while designing a GPIB program 

• The Parameters Reference section for incremental units and 
default values of TDSJIT3 parameters 

• The programmer information in the online help of your 
oscilloscope 

See Also 
Variable:Value TDS Command on page 108 
 
 
Starting and Setting Up the Application Using 
GPIB 
To start the TDSJIT3 application, you must send the oscilloscope 
the following GPIB command: 
application:activate "Jitter Analysis 3" 

The application uses the GPIB VARIABLE:VALUE command 
with arguments to execute some features. The set of GPIB 
commands does not include the variable names and variable 
values necessary to select and configure the measurements in the 
GPIB program. 
You must manually set up the application and oscilloscope, 
selecting and configuring the measurements that you want to use 
with your GPIB program, and save them in a setup file. To save 
a setup file, refer to the topic,  How to Save and Recall Setups. 
Use the name of the saved setup file as the value for the 
"recallName" variables in your GPIB program. 
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See Also 
Variable: Value Jitter3 Command below 
Variable:Value TDS Command Arguments and Queries 
beginning on page 105 
 
 
Variable: Value Jitter3 Command 
Description 
This command accepts string arguments for a control or data 
variable and a value to which to set the argument.  
Syntax 
VARIABLE:VALUE "<variable name>","<variable value>" 
Note: 
The arguments <variable name> and <variable value> are 
required in the order indicated. 
VARIABLE:VALUE? <variable name> for query. 
 

  CAUTION. Commands are case and space sensitive. 
Your program will not operate correctly if you do not follow the 
capitalization and spacing precisely. 
See Also 
Variable Value Jitter3 Command Arguments and Queries 
beginning on page 105 
Measurements Results Queries on page 108 
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Variable:Value Jitter3 Command Arguments and 
Queries -  Part 1 

Name Value Function Query form returns 
application {exit} Terminates the active 

application 
Name of the currently 
active application 

Sequencer    
sequencerMode {MeasureOnly, 

FreeRun, Single} 
Sets the sequencer mode Sequencer mode 

sequencerState {Stop, Sequencing} Send Measurement 
Sequencing command 

{Most recent set, 
Ready} 
*Ready indicates 
sequencing has 
stopped 

reset {Results} Clears the active 
measurement results and 
the plot displays 

{Most recent set, Read} 
*Ready indicates results 
have been cleared 

Save/Recall    
Setup* {Default, Recall} Performs the Recall of 

default or Recall of setup 
in Recall name 

{Most recent setting, 
Ready} 
Read indicates both 
application .ini and 
oscilloscope .set files 
were recalled  
May return an error 
message 

recallName * Any string from 1 to 
40 characters from A 
to Z and/or 0 to 9 or 
Special characters 
like “.” 

Sets the recalled setup 
file name.  Filename 
extension .ini is optional. 
The directory location of 
the file is the default 
(\TekApplications\TDSJIT
3\setup) if the app has 
been started via GPIB or 
in the most recent recall 
directory accessed from 
the GUI 

recall setup file name 
(without extension) 

recallDirectory Query only Confirms the location of 
recalled setup files 
directory. The directory 
location of the recall file is 
either the default 
(\TekApplications\TDSJIT
3 \setup) if the app has 
been started via GPIB or 
in the most recent 
recalled directory selected 
from the GUI 

Recalled setup files 
directory path.  String 
limit is 40 characters.  
The middle of a longer 
string will be shortened 
to “…” to bring the 
string length to 40 

*All queries that return Ready may return error text instead if an error is encountered 
  

 
 
Variable: Value Jitter3 Command Arguments and 
Queries - Part 2 
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Name Value Function Query form returns 
logStatsDirectory Query only Confirms the location of 

log directory. 
Log directory path.  
String limit is 40 
characters.  The middle 
of a longer string will be 
shortened to “…” to 
bring the string length to 
40. 

logStatsState {On, Off} Sets the state of the 
statistics log; when on, 
the statistics from the 
current acquisition are 
logged 

Current value 

logCurrentMeasurements {Now} Saves measurements into 
associated files 

{Most recent set, 
Ready} 
Ready indicates 
measurement logging 
completed 

logCurrentMeasurementsDir
ectory 

Query only Confirms the location of 
save measurements 
“now” directory. The 
directory location of the 
log file is either the default 
(\TekApplications\TDSJIT
3 
\measurementSnapshot) 
if the app has been 
started via GPIB or in the 
most recent log directory 
selected from the GUI. 

Save measurements 
now directory path.  
String limit is 40 
characters.  The middle 
of a longer string will be 
shortened to “…” to 
bring the string length to 
40. 

logMeasurementsState {On, Off} Sets the state of the 
measurements log; when 
on, the measurements 
from the current 
acquisition are logged 

Current value 

logWorstcaseState {On, Off} Sets the state of the 
Worstcase log; when on, 
the Worstcase from the 
current acquisition are 
logged 

Current value 

logWorstcaseDirectory Query only Confirms the location of 
log worst case waveforms 
directory. The directory 
location of the log file is 
either the default 
(\TekApplications\TDSJIT
3 
\measurementSnapshot) 
if the app has been 
started via GPIB or in the 
most recent log directory 
selected. 

Log worst case 
waveforms directory 
path.  String limit is 40 
characters.  The middle 
of a longer string will be 
shortened to “…” to 
bring the string length to 
40. 
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Variable: Value Jitter3 Command Arguments and 
Queries - Part 3 
 
Name Value Function Query from t 
Result Variables    
ResultFor* {Meas1, Meas2, 

Meas3, Meas4, 
Meas5, Meas6} 

Specifies the 
measurement for 
which results are 
requested 

Returns the 
selected 
measurement 
for the queries 
associated with 
resultFor** 

resultAcq {Current, All} Specifies desired 
measure set: 
either the current 
acquisition or all 
(accumulated) 
acquisition. 

Current value 

TIE RjDj/BER*** Applies to the measurement selected by the resultFor 
command if it is a TIE measurement 

RjDjBER*** {On, Off} Force the RjDj 
BER results to be 
updated. 

Current value 

RjDjBERTarget*** {range: 2…15, 
by 1} 

Set the exponent 
component of the 
BER (i.e., 10-?) 

Current value 

*After sequencing, send the resultFor command prior to querying results.  
**If there are fewer than six measurements, then resultFor returns the previous 
setting when a Meas# is set that does not exist 
***These commands are valid only for TDSJIT3. 

 
 
Variable: Value Jitter3 Command Arguments and 
Queries - Part 4 
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Variable Name Value Function Query Form 

Returns 
sourceScaleSelect {C1, C2, 

C3, C4} 
Selects the source to 
be autoscaled. 

Current value 

sourceScaleAutoset {Vert, 
Horiz, All} 

Starts autoset 
sequence 

{Most recent set, 
Ready} 
Ready indicates that 
scale Autoset is 
complete 

Source Ref Levels    

refLevelSelect {C1, C2, 
C3, C4, 
R1, R2, 
R3, R4, 
M1, M2, 
M3, M4} 

Selects the source ref 
level autoset. 

Current value 

refLevelAutoset {Selected, 
All} 

Starts autoset 
sequence.  Selected 
autosets source 
specified by 
refLevelSelect and All 
operates on all active 
sources. 

{Most recent set, 
Ready} 
Ready indicates Ref 
Level Autoset is 
complete 

Logging Results    

logCurrentStats {Now} Updates the current 
statistics log file 

{Most recent set, 
Ready} 
Ready stats logging 
is complete 

LogCurrentStatsDestinat
ion 

Any string 
from 1 to 
40 
characters 
from A to Z 
and/or 0 to 
9 or 
Special 
characters 
like “.” 

Sets the current 
statistics log file name. 
Filename extension 
.csv is optional. The 
directory location of 
the file is the default 
(\TekApplications\TDS
JIT3\log 

Current file name. 
(without extension) 

logCurrentStatsDirectory Query only Confirms the location 
of log directory. The 
directory location of 
the log file is either the 
default 
(\TekApplications\TDS
JIT3 \log) if the app 
has been started via 
GPIB or in the most 
recent log directory 
selected  

Log directory path.  
String limit is 40 
characters.  The 
middle of a longer 
string will be 
shortened to “…” to 
bring the string 
length to 40 

LogStatsDestination Any string 
from 1 to 
40 
characters 
from A to Z 
and/or 0 to 
9 or 
Special 
characters 
like “.” 

Sets the  statistics log 
file name. Filename 
extension .csv is 
optional. The directory 
location of the file is 
the default 
(\TekApplications\TDS
JIT3\log 

Current name name. 
(without extension) 
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logStatsDirectory Querry 
only 

Confirms the location 
of log directory. 

Log directory path.  
String limit is 40 
characters.  The 
middle of a longer 
string will be 
shortened to “…” to 
bring the string 
length to 40. 

logStatsState {On, Off} Sets the state of the 
statistics log; when on, 
the statistics from the 
current acquisition are 
logged 

Current value 

logCurrentMeasurement
s** 

{Now} Saves Measurements 
into associated files 

{Most recent set, 
Ready} 
Ready indicates 
value has been 
processed. 

logCurrentMeasurement
sDirectory 

Querry 
only 

Confirms the location 
of save measurements 
“now” directory. The 
directory location of 
the log file is either the 
default 
(\TekApplications\TDS
JIT3 
\measurementSnapsh
ot) if the app has been 
started via GPIB or in 
the most recent log 
directory selected from 
the GUI. 

Save measurements 
now directory path.  
String limit is 40 
characters.  The 
middle of a longer 
string will be 
shortened to “…” to 
bring the string 
length to 40. 

logMeasurementsState {On, Off} Sets the state of the 
measurements log; 
when on, the 
measurements from 
the current acquisition 
are logged 

Current value 

logWorstcaseState {On, Off} Sets the state of the 
Worstcase log; when 
on, the Worstcase 
from the current 
acquisition are logged 

Current value 

logWorstcaseDirectory Querry 
only 

Confirms the location 
of log worst case 
waveforms directory. 
The directory location 
of the log file is either 
the default 
(\TekApplications\TDS
JIT3 
\measurementSnapsh
ot) if the app has been 
started via GPIB or in 
the most recent log 
directory selected from 
the GUI. 

Log worst case 
waveforms directory 
path.  String limit is 
40 characters.  The 
middle of a longer 
string will be 
shortened to “…” to 
bring the string 
length to 40. 

Result Variables    
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ResultAcq {Current, 
All} 

Specifies desired 
measure set: either the 
current acquisition or 
all (accumulated) 
acquisition. 

Current value 

TIE RjDj/BER “Applies to the measurement selected by the resultFor command.” 

rjDjBER {On, Off} Force the RjDj BER 
results to be updated. 

Current value 

rjDjBERTarget {range: 
2…15, by 
1} 

Set the exponent 
component of the BER 
(i.e., 10-?) 

Current value 

 
 

 
Measurements Results Queries 

Caution: Prior to doing measurement queries, insert a 
delay of a second after the resultFor and the resultAcq 
commands to allow the statistics variables to be refreshed. 
You need to use the VARIABLE:VALUE? form to enter 
measurement results queries in your GPIB program. Before you 
can do this, you must first set the measurement with the resultFor 
command. You can select the Current or all acquisition statistics 
with the resultAcq command. 
The Table below lists the measurement results queries for the 
measurement selected in the resultFor variable. 
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Variable name For the measurement selected in the resultFor variable the query Returns the …. 
measurement  “key,source(s)” pair.  The key as an abbreviation for the selected measurement (e.g., 

“CP” for Clock Period.   Source(s) is an abbreviation for the source or sources associated 
with the measurement (e.g., “C1” for Channel 1 or C1C2 for a measurement that requires 
both Channel 1 and Channel 2.   

Statistics 
Results 

Basic statistics applicable for all measurements. 

measUnits Return a units string for the measurement (e.g., “s” for seconds for Period). 
max Maximum measurement value 
maxPosDev Magnitude of the largest positive change of the measurement  
maxNegDev Magnitude of the largest negative change of the measurement  
mean Mean value of the result  
min Minimum measurement value  
pkpk Peak-to-peak measurement value (max - min) 
population Population (number of) measurements used to the current statistics 
stdDev Standard deviation measurement set 
RjDj results Applies to TIE type measurements only.  For non-TIE measurements an empty string will 

be returned.  For TIE measurements with RjDj turned off a null string is returned. 
dataDependent Data dependent jitter component of the TIE Jitter 
dutyCycle Duty cycle jitter component of the TIE Jitter 
deterministic Determinstic jitter component of the TIE Jitter 
periodic Periodic jitter component of the TIE Jitter 
random Estimated random jitter component of the TIE Jitter 
totalJitter Estimated total jitter component at the designated BER of the TIE Jitter 
eyeOpening Estimated eye opening at the designated BER of the TIE Jitter 
Messages String that returns if App has problems  
error General error. 
measError Measurement specific errors. 
rjDjError RjDj analysis related error. 
warning Warning, if any, from the last measurement taken 

  
 
 

GPIB Program Example 
About the GPIB Program 
An example of a GPIB program that can execute the TDSJIT3 is 
included with the application. The oscilloscope hard disk and 
optional applications compact disc both contain the file, 
tdsjit3ctrl.c. On the hard drivethe file resides in the C:\Program 
Files\TekApplications\tdsjit3 directory. 
This example shows how a GPIB program executes the 
application to do the following tasks: 
• Start the application 
• Recall a setup 
• Enable logging 
• Take a measurement 
• Check for an error 
• Exit the application 
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Guidelines to GPIB Programming 
Your GPIB program should comply with the following 
guidelines: 
• The application startup must complete before sending 

additional GPIB commands to the application (see example) 
• The measurements cycle must complete before data is 

queried (see example). 
• The error variable should be checked to ensure that an error 

has not occurred because of a measurement command 
problem 

• GPIB event queue needs to be monitored. Make sure the 
event queue is clear before sending the next GPIB command 
to prevent event queue overflow 

Display the Program Example. 
See Also 
Introduction to GPIB Command Syntax  
GPIB Reference Materials  
Variable:Value TDS Command  
Variable:Value TDS Command Arguments and Queries  
Measurements Results Queries  
About the GPIB Program  
 
 
 

Program Example 
The reference program illustrates how to communicate to 
TDSJIT3 using Remote GPIB facilities. 
The program includes the following steps:  
1. Start up the application 
2. Recall a setup 
3. Take a measurement 
4. Display results or errors 
5. Exit the application 
 
For the current program, we will recall a setup file named as 
(setup). You can save setup files according to your own needs 
using the GUI-based interface of the application. 
 
*/ 
 
 
#ifdef __cplusplus 
extern "C"{ 
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#endif 
#include <windows.h> 
#include <stdio.h> 
#include <stdlib.h> 
#include "decl-32.h" 
#ifdef __cplusplus 
} 
#endif 
 
/* Forward Declarations */ 
int start_application(int scope); 
int exit_application(int scope); 
int do_single_test (int scope); 
int recall_setup( int scope, char 
*filename); 
void display_results(int scope); 
 
/* parameters needed to access the device 
driver handler */ 
#define BDINDEX 0    // 
Board Index 
#define PRIMARY_ADDR_OF_DMM 1 // Primary 
address of device 
#define NO_SECONDARY_ADDR 0  // 
Secondary address of device 
#define TIMEOUT T10s   // Timeout 
value = 10 seconds 
#define EOTMODE 1    // 
Enable the END message 
#define EOSMODE 0    // 
Disable the EOS mode 
char    ErrorMnemonic[21][5] = {"EDVR", 
"ECIC", "ENOL", "EADR", "EARG", 
       
 "ESAC", "EABO", "ENEB", "EDMA", "", 
       
 "EOIP", "ECAP", "EFSO", "", "EBUS", 
       
 "ESTB", "ESRQ", "", "", "", "ETAB"}; 
 
/* 
* After each GPIB call, the application 
checks whether the call 
* succeeded. If an NI-488.2 call fails, the 
GPIB driver sets the 
* corresponding bit in the global status 
variable. If the call 
* failed, this procedure prints an error 
message, takes 
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* the device offline and exits. 
*/ 
 
void GPIBCleanup(int ud, char* ErrorMsg) 
{ 
 printf("Error : %s\nibsta = 0x%x iberr 
= %d (%s)\n", 
   ErrorMsg, ibsta, iberr, 
ErrorMnemonic[iberr]); 
 if (ud != -1) 
 { 
  printf("Cleanup: Taking device 
offline\n"); 
  ibonl(ud, 0); 
 } 
 exit(0); 
} 
 
 
int start_application( int scope ) { 
 char write_buffer[100]; 
 char read_buffer[100]; 
 char app_name[] = "\"TDSJIT3\"\n"; 
 int status, timer; 
 
 /* Start the Jitter Analysis 
application */ 
 sprintf(write_buffer, "%s", 
"Application:activate \"Jitter Analysis 
3\""); 
 status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 if (ibsta & ERR){ 
  GPIBCleanup(scope, "Unable to 
start the application"); 
  return 0; 
 } 
 
 timer = 1; 
 while (1) { 
 /* Check whether application has 
started */ 
  sprintf(write_buffer, "%s", 
"Variable:value? \"application\""); 
  status = ibwrt(scope, 
write_buffer, strlen(write_buffer)); 
  status = ibrd(scope, 
read_buffer, sizeof(read_buffer)); 
  read_buffer[ibcnt] = '\0'; 
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  if (strcmp(app_name, 
read_buffer) == 0) { 
   return 1; 
  } 
  timer++; 
  if (timer > 60) { 
   return 0; 
  } 
  Sleep(1000); 
 } 
 return 1; 
} 
 
 
int exit_application(int scope) { 
 char write_buffer[100]; 
 printf("Exit Application ...\n"); 
 sprintf(write_buffer, "%s", 
"Variable:value \"application\",\"exit\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 return 1; 
} 
 
 
int recall_setup(int scope, char* filename) 
{ 
 char write_buffer[100]; 
 char readBuffer[100]; 
 int status; 
 int timer; 
 
 /* Set Recall file directory */ 
 sprintf(write_buffer, "%s", 
"Variable:value 
\"setupDirectory\",\"Default\""); 
 status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 if (ibsta & ERR){ 
  GPIBCleanup(scope, "Unable to 
communicate with Scope"); 
  return 0; 
 } 
 
 Sleep(1000);  
 
 /* Set Recall file name */ 
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 sprintf(write_buffer, "%s%s%s", 
"Variable:value \"recallName\",\"", 
filename, "\""); 
 status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 if (ibsta & ERR){ 
  GPIBCleanup(scope, "Unable to 
communicate with Scope"); 
  return 0; 
 } 
 
 Sleep(1000); 
 
 /* Recall setup */ 
 sprintf(write_buffer, "%s", 
"Variable:value \"setup\",\"Recall\""); 
 status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 if (ibsta & ERR){ 
  GPIBCleanup(scope, "Unable to 
communicate with Scope"); 
 return 0; 
 } 
 
 /* Check whether recall is complete or 
not...If recall is complete 
 variable setup value will change to a 
"Ready" string */ 
 timer = 1; 
 while (1) { 
  timer++; 
  if (timer > 60) { 
   return 0; 
  } 
  Sleep(1000); 
  sprintf(write_buffer, "%s", 
"Variable:value? \"setup\""); 
  ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
  ibrd(scope, readBuffer, 99); 
  if (ibsta & ERR) { 
   GPIBCleanup(scope, "Unable 
to write to device"); 
  } 
  readBuffer[ibcnt] = '\0'; 
  if 
(strcmp(readBuffer,"\"Ready\"\n") == 0) { 
   printf("Recall Complete 
...\n"); 
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   return 1; 
  } 
  Sleep(1000); 
 } 
 return 1; 
} 
 
 
int do_single_test (int scope){ 
 char write_buffer[100]; 
 char read_buffer[100]; 
 int timer; 
 sprintf(write_buffer, "%s", 
"Variable:value 
\"sequencerState\",\"Sequencing\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 printf("Executing Test...\n"); 
 Sleep(100); 
 
 /* Wait for application to come to 
Ready State */ 
 timer = 1; 
 while (1) { 
  timer++; 
  if (timer > 90) { 
   printf("******Test Time Out 
******\n"); 
   return 0; 
  } 
  sprintf(write_buffer, "%s", 
"Variable:value? \"sequencerState\""); 
  ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
  ibrd(scope, read_buffer, 99); 
  if (ibsta & ERR) { 
   GPIBCleanup(scope, "Unable 
to write to device"); 
  } 
  read_buffer[ibcnt] = '\0'; 
  if 
(strcmp(read_buffer,"\"Ready\"\n") == 0) { 
   printf("Test Complete 
...\n"); 
  return 1; 
  } 
  Sleep(1000); 
 } 
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} 
 
 
void display_results(int scope) { 
 
 char write_buffer[100]; 
 char read_buffer[100]; 
  
 /* Check for errors */ 
 sprintf(write_buffer, "%s", 
"Variable:value? \"error\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 ibrd(scope, read_buffer, 99); 
 if (ibsta & ERR) { 
  GPIBCleanup(scope, "Unable to 
write to device"); 
 } 
 read_buffer[ibcnt] = '\0'; 
 if (strcmp(read_buffer,"\"\"\n") != 0) 
{ 
  printf("Error has Occured. 
Error: %s\n",read_buffer); 
 return; 
 } 
  
 /* If no error, check for results */ 
 sprintf(write_buffer, "%s", 
"Variable:value \"resultFor\",\"Meas1\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 Sleep(2000); 
 printf("\tFirst Measurement 
Result\n"); 
  
 /*  Mean  */ 
 sprintf(write_buffer, "%s", 
"Variable:value? \"mean\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 ibrd(scope, read_buffer, 99); 
 read_buffer[ibcnt] = '\0'; 
 printf("mean:%s\n", read_buffer); 
 
 /*  Max  */ 
 sprintf(write_buffer, "%s", 
"Variable:value? \"max\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
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 ibrd(scope, read_buffer, 99); 
 read_buffer[ibcnt] = '\0'; 
 printf("max:%s\n", read_buffer); 
 
 /*  Min  */  
 sprintf(write_buffer, "%s", 
"Variable:value? \"min\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 ibrd(scope, read_buffer, 99); 
 read_buffer[ibcnt] = '\0'; 
 printf("min:%s\n", read_buffer); 
  
 /*  PkPk  */  
 sprintf(write_buffer, "%s", 
"Variable:value? \"pkpk\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 ibrd(scope, read_buffer, 99); 
 read_buffer[ibcnt] = '\0'; 
 printf("pkpk:%s\n", read_buffer); 
  
 /*  stdDev  */  
 sprintf(write_buffer, "%s", 
"Variable:value? \"stdDev\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 ibrd(scope, read_buffer, 99); 
 read_buffer[ibcnt] = '\0'; 
 printf("stdDe:v%s\n", read_buffer); 
  
 /*  population  */  
 sprintf(write_buffer, "%s", 
"Variable:value? \"population\""); 
 ibwrt(scope, write_buffer, 
strlen(write_buffer)); 
 ibrd(scope, read_buffer, 99); 
 read_buffer[ibcnt] = '\0'; 
 printf("population:%s\n", 
read_buffer); 
} 
 
 
int main(){ 
 
 int Dev; 
 char write_buffer[100]; 
 int status; 
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 Dev = ibdev (BDINDEX, 
PRIMARY_ADDR_OF_DMM, NO_SECONDARY_ADDR, 
 TIMEOUT, EOTMODE, EOSMODE); 
 if (ibsta & ERR){ 
  GPIBCleanup(Dev, "Unable to open 
device"); 
 } else { 
  printf("My device id - %i", 
Dev); 
 } 
 sprintf(write_buffer, "%s", "header 
off"); 
 status = ibwrt(Dev, write_buffer, 
strlen(write_buffer)); 
 if (start_application(Dev)) { 
  printf("\nApplication 
started....\n"); 
 } 
 Sleep(2000); 
 recall_setup(Dev, "setup"); 
 Sleep(2000); 
 do_single_test(Dev); 
 /* Print the results */ 
 display_results(Dev); 
 exit_application(Dev); 
 /* leave the device back elegantly */ 
 printf("Cleanup: Taking device 
offline\n"); 
 ibonl(Dev, 0); 
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